LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Sendmail: block specific sender to specific recipient - How? (http://www.linuxquestions.org/questions/linux-server-73/sendmail-block-specific-sender-to-specific-recipient-how-759114/)

thekillerbean 10-01-2009 09:09 PM

Sendmail: block specific sender to specific recipient - How?
 
I'm trying to configure our mail server to block email from a specific sender reaching a specific recipient. In other words, if one of our employees is getting harassed by a 'stalker', how would one go about blocking, at the MTA (Sendmail) level, a specific sender email address from reaching a particular users inbox? We do not want to capture the email - simply block it before it consumes server resources.

The Sendmail server (MTA) is a front end to our Exchange server so no user accounts exist on the Linux server. We simply use it as a SPAM and Virus scanner then forward clean email to the Exchange server.

Any and all help appreciated!

Tia,
tkb.

thekillerbean 10-01-2009 09:33 PM

Solved
 
I read the Sendmail, 3rd Edition book and resolved the issue.

Mainly, I had to add
FEATURE(`check_compat')
in the /etc/mail/sendmail.mc file

Then I had to create the following entries
Compat:sender@domain.com<@>recipient@ourdomain.com DISCARD
in /etc/mail/access file

Easy as pie; well, after a bit of reading...

Cheers,
tkb.

jmahto 10-14-2009 05:24 AM

Quote:

Originally Posted by thekillerbean (Post 3704493)
I read the Sendmail, 3rd Edition book and resolved the issue.

Mainly, I had to add
FEATURE(`check_compat')
in the /etc/mail/sendmail.mc file

Then I had to create the following entries
Compat:sender@domain.com<@>recipient@ourdomain.com DISCARD
in /etc/mail/access file

Easy as pie; well, after a bit of reading...

Cheers,
tkb.



After doing that its not working can you tell me step by step

J Mahto

okcomputer44 10-14-2009 06:21 AM

Quote:

Originally Posted by jmahto (Post 3718671)
After doing that its not working can you tell me step by step

J Mahto

Hi,

this is the step by step instructions for you: http://docstore.mik.ua/orelly/other/...-7-sect-5.html

Take a look the "FEATURE(`check_compat')" part.

Laz

jmahto 10-15-2009 02:00 AM

Quote:

Originally Posted by okcomputer44 (Post 3718713)
Hi,

this is the step by step instructions for you: http://docstore.mik.ua/orelly/other/...-7-sect-5.html

Take a look the "FEATURE(`check_compat')" part.

Laz



Thanking you for your post , but we need something diffrent from this
basically we need to block any entire domain and realy some email IDs of such domain like

Emails should not relay to xyz domain except some ids of such domain

abc@xyz.com should relay but

other Ids should not


Thanks and Regards,

J Mahto

okcomputer44 10-15-2009 08:19 AM

Quote:

Originally Posted by jmahto (Post 3719907)
Thanking you for your post , but we need something diffrent from this
basically we need to block any entire domain and realy some email IDs of such domain like

Emails should not relay to xyz domain except some ids of such domain

abc@xyz.com should relay but

other Ids should not


Thanks and Regards,

J Mahto

That is easy too just put the address into access file and discard it or reject it.

Quote:

From:spammer@some.dom REJECT
To:friend.domain RELAY
Connect:friend.domain OK
Connect:from.domain RELAY
From:good@another.dom OK
From:another.dom REJECT
like that.

Ref.: http://www.sendmail.org/m4/anti_spam.html

Laz

jmahto 07-13-2010 04:13 AM

httpd-2.2.3 | error - suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
 
I am installing the centos 5.4 and start the services of httpd, mysqld, and squid. After that i am configure the mysar (Squid reporting tool). After that when i am restart the service httpd its show --- FAILED. and after that i see the the /var/log/httpd/error_log ---->

[Tue Jul 13 12:11:15 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)


Its shows the above error. i am not able to start the httpd services.

Please suggest me.

Thanks in advance.

J Mahto.


All times are GMT -5. The time now is 01:12 PM.