LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Secondary DNS server (setup) w/ a windows domain (http://www.linuxquestions.org/questions/linux-server-73/secondary-dns-server-setup-w-a-windows-domain-606825/)

krazyglue 12-14-2007 03:26 PM

Secondary DNS server (setup) w/ a windows domain
 
I am looking to setup a secondary DNS server for my Mixed Windows and Linux network.

Currently, I have the primary DNS server (and AD) running on a windows 2003 server. The box that I will be using for the secondary DNS server is a Red Hat FC4 box.

Does anyone have a good detailed set of instructions or a good website to use to set up a secondary DNS server on a linux box?

Is BIND the best idea to try to configure?

I am at the early stages of setting up the DNS server on the linux box so I am flexable as to what program to use and how its configured. I was hoping someone has done this before and can give me pointers as to what works best and what doesn't work so well.

Micro420 12-16-2007 03:14 AM

You just set up your Linux box to be a slave server

Make sure to allow zone transfers on your Windows Server 2003 so that the slave server can get the updates

I am only familiar with BIND for setting up nameservers.

krazyglue 12-17-2007 02:02 PM

Thanks for the information. I have successfully implemented this today and I am getting zone transfers working correctly. If anybody cares here are the steps to do this. Also, if someone would be kind and help me clean up my “named.conf” file below that would be great!

Step 1 edit /etc/named.conf file. After you have edit the file restart the named service by typing in "service named restart" at the command line. Below is my configuration. I have edit out a few IPs so here is a key.

x.x.x.x – ISPs Primary DNS server
y.y.y.y – ISPs secondary DNS server
z.z.z.z – Internal Primary DNS server
a.b.c.d – Internal IP address scheme (used for reverse lookups)


//
// named.conf for Red Hat caching-nameserver
//

options {
forwarders { x.x.x.x port 53;
y.y.y.y port 53;
};

directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
statistics-file "/var/named/data/named_stats.txt";
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
// query-source address * port 53;
};

//
// a caching only nameserver config
//
controls {
inet 127.0.0.1 allow { localhost; } keys { rndckey; };
};

zone "yourdomainname.com." IN {
masters { z.z.z.z port 53;
};
type slave;
file "slaves/yourdomainname.com.db";

};

zone "c.b.a.in-addr.arpa" {
type slave;
file "slaves/yourdomainname.com.db.zone";
masters {z.z.z.z;};
};

zone "." IN {
type hint;
file "named.ca";
};

zone "localdomain" IN {
type master;
file "localdomain.zone";
allow-update { none; };
};

zone "localhost" IN {
type master;
file "localhost.zone";
allow-update { none; };
};

zone "0.0.127.in-addr.arpa" IN {
type master;
file "named.local";
allow-update { none; };
};

zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa" IN {
type master;
file "named.ip6.local";
allow-update { none; };
};

zone "255.in-addr.arpa" IN {
type master;
file "named.broadcast";
allow-update { none; };
};

zone "0.in-addr.arpa" IN {
type master;
file "named.zero";
allow-update { none; };
};

include "/etc/rndc.key";


Step 2 allow zone transfers on Windows DNS server:
1. Start ->run “dnsmgmt.msc”
2. Expand “Forward lookup zone”
3. right click on yourdomainname.com go to properties
4. “zone transfer” tab
5. check “Allow zone transfers”
6. “only to the following servers”
7. add IP address of linux slave DNS server
8. Apply and ok.
9. Expand “Reverse looup zone”
10. right click on a.b.c.x subnet
11. “zone transfer” tab
12. check “Allow zone transfers”
13. “only to the following servers”
14. add IP address of linux slave DNS server
15. Apply and ok.


All times are GMT -5. The time now is 08:26 PM.