LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 05-07-2011, 02:59 PM   #1
Teckno
Member
 
Registered: May 2004
Location: Why do you want to know?
Posts: 82

Rep: Reputation: 15
Unhappy Samba won't authenticate users


I'm just trying to set up a simple file server on my OpenIndiana box, but no matter what tutorial or smb.conf setting I seem to try I get the same problem.

First, my latest smb.conf:
Code:
[global]
	netbios name = CASPER
	workgroup = LAN
	server string = File Server
	log file = /var/samba/log/smbd.log
	max log size = 100
	encrypt passwords = yes
	smb passwd file = /etc/samba/smbpasswd
	security = share
	unix password sync = Yes
	passwd program = /usr/bin/passwd %u
	passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*	
	socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192	

[media]
	comment = Media Files
	path = /share/media
	public = yes
	read only = no
		
[sam]
	comment = Sams Files
	path = /share/userfiles/sam
	valid users = sam
	public = no
	writable = yes
	printable = no
I also made sure to add both the unix user and smb user to the server. I have the same user name "sam" on my windows desktop, and ubuntu laptop, and I used the same password. Ive tested the accounts and they seem to work fine. I can login to the unix account and samba shows that it has a user named sam

The problem:
The server and shares show up just fine, and the media share is readable (not writable but that most likely just a permission thing and not the issue at hand). The problem is with the private share "sam", heres what happens:

Local Test:
[QUOTE]sam@casper:~$ /usr/bin/smbclient //192.168.0.1/sam
Enter sam's password:
Connection to 192.168.0.1 failed (Error NT_STATUS_CONNECTION_REFUSED)[/CODE]

From my Ubuntu laptop:
Quote:
sam@osaka:~$ smbclient //192.168.1.13/sam
Enter sam's password:
session setup failed: NT_STATUS_LOGON-FAILURE
And from my Windows Vista desktop I just get a login unsuccessful message.

My /var/samba/log/smbd.log is filled with these:
Code:
[2011/05/07 13:46:32.075667,  1] smbd/service.c:677(make_connection_snum)
  create_connection_server_info failed: NT_STATUS_WRONG_PASSWORD
[2011/05/07 13:46:32.079670,  1] smbd/service.c:677(make_connection_snum)
  create_connection_server_info failed: NT_STATUS_WRONG_PASSWORD
[2011/05/07 13:46:32.086242,  1] smbd/service.c:677(make_connection_snum)
  create_connection_server_info failed: NT_STATUS_WRONG_PASSWORD
and yes, I triple checked all the passwords.


From my tests it seems that samba refuses to use any sort of user other then the guest account.

I tried it with "security = user" but run into the same issue, just when I connect to the server instead of the share, so it efectivlly blocks me from the media share as well.

Im probably missing something simple thats preventing the authentication, anyone care to point it out?

Thank you
 
Old 05-09-2011, 01:25 PM   #2
Teckno
Member
 
Registered: May 2004
Location: Why do you want to know?
Posts: 82

Original Poster
Rep: Reputation: 15
Ive tried all I can think of, is there any other test I could run to gather more information on this?
 
Old 05-11-2011, 01:00 PM   #3
Teckno
Member
 
Registered: May 2004
Location: Why do you want to know?
Posts: 82

Original Poster
Rep: Reputation: 15
Does anyone have any idea what other files or programs are used in the process?

That way I can go though them one by one and check them out.
 
Old 05-14-2011, 02:27 PM   #4
Teckno
Member
 
Registered: May 2004
Location: Why do you want to know?
Posts: 82

Original Poster
Rep: Reputation: 15
Can someone at least confirm that the smb.conf looks good (Im not missing anything)?
 
Old 05-25-2011, 01:44 PM   #5
Teckno
Member
 
Registered: May 2004
Location: Why do you want to know?
Posts: 82

Original Poster
Rep: Reputation: 15
Unhappy

Ok, this is weird. This is only one of three forums I posted this to and I have yet to get a reply from anyone. Does no one use Samba? should I be looking at something else?

I know this is possible since thats the whole point of samba authentication, and Ive followed the examples to the letter. What the hell is going on with this thing?
 
Old 05-25-2011, 02:07 PM   #6
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,512
Blog Entries: 27

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
Did you run smbpasswd?
 
Old 05-26-2011, 01:26 PM   #7
Teckno
Member
 
Registered: May 2004
Location: Why do you want to know?
Posts: 82

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by catkin View Post
Did you run smbpasswd?
weird, I could have sworn I ran this before but I don't recall getting this error before:

Code:
sam@casper:~$ /usr/bin/smbpasswd
Old SMB password:
New SMB password:
Retype new SMB password:
SAMR connection to machine NT_STATUS_ACCESS_DENIED failed. Error was 127.0.0.1, but LANMAN password changed are disabled
Ok, ran as root:
Code:
# smbpasswd -a sam
New SMB password:
Retype new SMB password:
no errors came up but I still cant access the share, sames issues as before
 
Old 05-28-2011, 05:10 AM   #8
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,512
Blog Entries: 27

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
Probably a silly question but did you give sam the same password with smbpasswd that sam has on Windows?

Probably doesn't matter but are the Windows systems in workgroup LAN?

To minimise/canonicalise the problem information, what is the output of testparm smb.conf?

NFS would be a better choice than Samba for your Ubuntu system.
 
Old 05-28-2011, 07:04 PM   #9
Teckno
Member
 
Registered: May 2004
Location: Why do you want to know?
Posts: 82

Original Poster
Rep: Reputation: 15
Yes and yes, same password, and the workgroup is LAN

However...

Code:
# testparm smb.conf
Load smb config files from smb.conf
rlimit_max: rlimit_max (256) below minimum Windows limit (16384)
params.c:OpenConfFile() - Unable to open configuration file "smb.conf":
        No such file or directory
Error loading services.
 
Old 05-28-2011, 11:58 PM   #10
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,512
Blog Entries: 27

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
Sorry for not being more explicit. Assuming smb.conf is in /etc/samba, you need either
Code:
cd /etc/samba
testparm smb.conf
or
Code:
testparm /etc/samba/smb.conf
 
Old 10-01-2012, 09:36 AM   #11
Perplexed
LQ Newbie
 
Registered: Apr 2010
Location: London
Distribution: CentOS 5.8
Posts: 2

Rep: Reputation: 0
System Date

I realize this is an old thread, but it showed up high in search results and seems to lack a conclusion.

I had similar problems, but setting the system date on the serving CentOS box to today's date (from 2004!) may have been the solution for me, and the reason why clients weren't being happily connected.
 
Old 10-29-2012, 04:51 AM   #12
Nick_C
Member
 
Registered: Jan 2012
Location: London, England, UK
Distribution: CentOS, Mageia, Debian, Fedora, openSUSE, Ubuntu
Posts: 228

Rep: Reputation: Disabled
I know this is an old thread but I just came accross it while trying to solve the same problem. So for the benefit of others that might happen accross it.

The answer:
Problem is caused by SELinux, it can be turned off temporarily with 'setenforce 0', if that works turn it back on with 'setenforce 1' and correct the problem properly by setting the context of the Samba share directory to samba_share_t.

Hope that might help.
 
Old 03-14-2013, 02:10 PM   #13
EastLight
LQ Newbie
 
Registered: Mar 2013
Posts: 1

Rep: Reputation: Disabled
I know this is an old thread, but it continues to rank highly in search results for this issue.

I had the same problem - when Samba security was set to 'share' on my Linux box, authentication failed when attempting to access a password protected share from Windows 7, even though username and password were both entered correctly.

A partial clue came from a Microsoft support article named 'Cannot Connect to Password-Protected Share on Windows 95/98 Computer', since Win95/98 also use 'share level' security.

Basically, to access the password-protected Samba share in Windows 7, when the 'Enter Network Password' box pops up, instead of just entering the Linux user account name you need to enter name of Linux box\Linux user account name.
So if the Linux box is named 'dragon', the user account is named 'bob' and the password is 'penguin' you would enter:
Username: dragon\bob
Password: penguin

This worked for me - hope it helps others too.

Last edited by EastLight; 03-14-2013 at 02:47 PM.
 
Old 03-15-2013, 02:16 AM   #14
zafar_dandoti
Member
 
Registered: Dec 2005
Location: India
Distribution: Fedora 17,ubuntu,centos 6.3
Posts: 63

Rep: Reputation: 6
have you checked the actual directory permissions on samba server...?
does user sam have read/write access to directories ?
what are directory permissions please elaborate ..
 
Old 03-15-2013, 02:25 AM   #15
zafar_dandoti
Member
 
Registered: Dec 2005
Location: India
Distribution: Fedora 17,ubuntu,centos 6.3
Posts: 63

Rep: Reputation: 6
probably you must have created directories by becoming root so the directories are owned by user root!

modify the directory permissions so that samba users can read/write to them..
 
  


Reply

Tags
authentication, samba, share, users


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba: New AD users can't authenticate warci Linux - Networking 2 04-10-2006 02:18 AM
Authenticate samba users against PAM yapp Linux - Networking 0 11-24-2005 05:59 AM
authenticate samba users using the NIS manojthakkar Linux - Networking 1 07-25-2005 07:48 PM
authenticate samba users using the NIS manojthakkar Linux - General 1 02-02-2004 02:25 PM
authenticate samba users using the NIS manojthakkar Linux - Newbie 1 02-02-2004 11:45 AM


All times are GMT -5. The time now is 06:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration