LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 02-21-2009, 08:54 PM   #1
cougar97536
LQ Newbie
 
Registered: Jan 2006
Location: Prospect, Oregon, USA
Distribution: Fedora Core and Mandriva
Posts: 6

Rep: Reputation: 0
samba permissions Issues


Hey all, I am running Ubuntu Server 8.10, and trying to setup a samba box. I have samba configured so that the proper folders are shared, and all the windows workstations (xp & vista) can see the shares. My problem is a permissions issue. if I issue the command
sudo chmod -R 770 folderName
then whoever writes to a file first has full access. however the permissions are being set to something like owner rwx group r__ other ___ . this is not what I want at all... any Idea how I can stop the file permissions from changing during editing? Excel 2003...
thanks for your help,
Christopher King

ps: it has been suggested that it might be something called "Opportunistic locking" but I have no real understanding of what this is...
 
Old 02-21-2009, 09:42 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Is only one user or group allowed to access the share?

You don't want to set the 'x' bit on files in a share. You do need them for directories.

Check if you have a "create mask" entry in your smb.conf file. The default is 0744. Also check for "directory mask". The default is 0744.

A Linux user saving a file will have the umask environment variable mask of bits of created files.

If you have more than one user that is able to write to the share, you want to enable the 'o' bit on the share's directory. The default for a public share is the same as the /tmp directory, created with "chmod ugo=rwxt". The sticky bit prevents one user from deleting the file of another user.

Also look at "force create mode" and "force directory mode" if you want documents and directories to have certain unix permissions set (or'ed).

I think that opportunistic locking will only affect files that are being edited by another user, not after they are done.
 
Old 02-21-2009, 11:40 PM   #3
cougar97536
LQ Newbie
 
Registered: Jan 2006
Location: Prospect, Oregon, USA
Distribution: Fedora Core and Mandriva
Posts: 6

Original Poster
Rep: Reputation: 0
thanks

Thank you, that SEEMS to have fixed the issue, I just added the following lines to the smb.conf file

create mask = 0770
directory mask = 0770

and it seems to no longer have any permission issues...
have a great one,
Christopher King
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba domain member server (DMS) group permissions in network with a Samba PDC srosa Linux - Networking 0 05-01-2006 05:55 PM
Application permissions issues motionid Linux - Newbie 4 08-07-2005 11:24 AM
New to linux, so so lost, auto mounting issues, permissions issues slowhand22 Linux - Newbie 2 02-10-2005 09:41 AM
SAMBA says 'Samba Server is not accebile, you might have no permissions' Ahmad Gurchani Linux - General 1 01-01-2005 10:34 AM
permissions issues goldenmag Linux - General 3 08-01-2003 08:43 AM


All times are GMT -5. The time now is 03:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration