LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 11-15-2011, 07:37 PM   #1
fmillion
Member
 
Registered: Nov 2006
Posts: 91

Rep: Reputation: 27
Samba: OS X overriding force permissions settings?


In reference to my post a few days ago, I gave in and decided to bite the bullet and work with UNIX permissions to implement what I wanted.

Now I face a new problem. Samba doesn't seem to be obeying the "force security mode" option.

Here's the settings for the share in question:

Code:
[tmp]
   read only = yes
   path = /nas/tmp
   write list = admin nas
   force group = nas
   inherit permissions = yes
   force security mode = 660
   force directory mode = 0775
   force create mode = 0664
   hide unreadable = yes
   veto files = /lost+found/._*/.DS_Store/.Trashes/._Trashes/
   browseable = no
The folder being shared (/nas/tmp) has permissions drwxrwxr-x and is owned by "admin" and group "nas". All files within the folder structure have group writable permission set. This means I can just create users and add them to group nas to allow them write access to the entire share. It also means I can restrict read or write access on a per-file or per-folder basis.

Now, I connect to this share from Windows and create a folder. If I look at that folder on the server, it indeed was created with permissions drwxrwxr-x as expected.

Code:
root [ /nas/tmp ]# ls -l
...
drwxrwxr-x  2 admin nas       4096 Nov 15 14:46 windows_folder
...
Enter Mac OS X. When I connect from my Mac to the share as either "nas" or "admin" and create a folder, it's created with permissions drwxr-xr-x. This of course means group nas can't write to that folder.

Code:
root [ /nas/tmp ]# ls -l
...
drwxr-xr-x  2 admin nas       4096 Nov 15 14:47 mac_folder
...
My goal, obviously, is to force all files created on the server to be writable by the group. This way I can simply set permissions on a folder I don't want accessed to drwx------ and the hide unreadable option will hide the files in question.

Am I missing something - is there a reason I can't get Samba to force files created from OS X to have the permissions I want? My guess is OS X is manipulating the permissions on files directly (it IS unix, after all) and that's why I tried setting force security mode - but it didn't work.

Advice?

FM

Last edited by fmillion; 11-15-2011 at 07:42 PM.
 
Old 11-18-2011, 08:42 AM   #2
benhanson
Member
 
Registered: Jan 2005
Posts: 39

Rep: Reputation: 15
Try setting
unix extensions = no
before the share
 
  


Reply

Tags
permissions, samba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
samba and mix mode security.. is it posible ? spatieman Linux - Server 0 09-02-2011 11:44 AM
Samba 'force create mode = 664' ignored (RHEL 5) hillersa Linux - Server 2 03-25-2009 06:34 AM
how to force monitor into 120hz mode? hedpe Linux - Software 1 10-10-2008 06:25 AM
LXer: Configuring Samba 3.0 To Use The ADS Security Mode (CentOS) LXer Syndicated Linux News 0 06-27-2007 10:31 AM
Samba security "permissions" in DOMAIN mode tisource Linux - Networking 3 05-09-2002 09:41 PM


All times are GMT -5. The time now is 01:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration