LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Samba 'force create mode = 664' ignored (RHEL 5) (http://www.linuxquestions.org/questions/linux-server-73/samba-force-create-mode-%3D-664-ignored-rhel-5-a-712002/)

hillersa 03-16-2009 11:46 AM

Samba 'force create mode = 664' ignored (RHEL 5)
 
Dear Linux users,

I am using RHEL 5 and an installation of samba from the repositories. In order to allow anyone in the group to write and delte files on a share, I have set the directives

'force create mode = 664' and
'force directory mode = 775'

in the smb.conf. Unfortunetaly, these are not met. After creating a file from a Vista client, the permissions are 644, no matter what I 'force'. Has anyone encountered a similar issue, and what could be the cause of this?

best regards, André

chitambira 03-17-2009 06:08 AM

Quote:

'force create mode = 664'
The modes in this parameter are bitwise 'OR'ed onto the file mode after the mask set in the create mask parameter is applied.
Note that default for create mask is 744. What is your set to? If you do not have it, its best to configure it and put create mask = 764

hillersa 03-25-2009 06:34 AM

Hello chitambira,

thank you for your answer, unfortunetaly I was busy with another project last week, so I am replying a little late.

My directory mask is now set to 775' and my create mask is set to '664', which solved the problem i guess,

best regards, André


All times are GMT -5. The time now is 07:38 AM.