LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Samba "Access Deny" when writing to share (http://www.linuxquestions.org/questions/linux-server-73/samba-access-deny-when-writing-to-share-513714/)

OpenVP 12-26-2006 03:20 AM

Samba "Access Deny" when writing to share
 
can some one kindly help me with Samba setup before i go crazy.

this is my smb.conf:


Code:


[global]
        workgroup = HOME
        os level = 20
        netbios name = linuxserver.no-ip.biz
        encrypt passwords = yes
        security = share

[linux]
        comment = Linux Share
        writeable = yes
        public = yes
        read only = no
        write list = saleh,@saleh
        path = /linux
        allow hosts = 192.168.1.2


i can browse this share from my windows XP and red files, but i cany write to it. i get "Access Deny".

folder permission is ok:

[root@saleh ~]# ls -al / |grep linux
drwxrwxrwx 5 saleh saleh 4096 Dec 26 10:12 linux


also in windows my workgroup name is : HOME


also: in the linux server i have the user "saleh" on both /etc/password and samba user file, plus the same user and password on windows.


192.168.1.2 is my windows XP IP

mindsport 12-26-2006 04:35 AM

the path is /root/saleh/linux or /linux? that part is the only thing that looks fishy to me. this is my samba conf if it will help:

Code:

[Linux1]
  comment = 300GB Linux Hard Drive
  path = /home/mind/300gb
  read only = no
  public = yes

[Linux2]
  comment = 70GB Linux Hard Drive
  path = /home/mind/70gb
  read only = no
  public = yes

[Music]
  comment = Music Drive
  path = /home/mind/Warez/Music
  read only = yes
  public = yes


OpenVP 12-26-2006 07:24 AM

the path is ok. i want to share /linux
i have this permission on this folder:

[root@saleh ~]# ls -al / |grep linux
drwxrwxrwx 5 saleh saleh 4096 Dec 26 10:12 linux


i think the problem is something other then samba (selinux) for example but i have selinux disable and no firewall.

OpenVP 12-26-2006 07:57 AM

i found the problem

it was selinux

i thoout selinux was disabled on this box but i was wrong ( system-config-securitylevel show me that its disabled)

i had to run this commands:

[root@saleh ~]# setsebool -P smbd_disable_trans 1
[root@saleh ~]# service smb restart
Shutting down SMB services: [ OK ]
Shutting down NMB services: [ OK ]
Starting SMB services: [ OK ]
Starting NMB services: [ OK ]


All times are GMT -5. The time now is 01:18 AM.