LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 03-16-2009, 11:46 AM   #1
hillersa
LQ Newbie
 
Registered: Mar 2009
Posts: 2

Rep: Reputation: 0
Samba 'force create mode = 664' ignored (RHEL 5)


Dear Linux users,

I am using RHEL 5 and an installation of samba from the repositories. In order to allow anyone in the group to write and delte files on a share, I have set the directives

'force create mode = 664' and
'force directory mode = 775'

in the smb.conf. Unfortunetaly, these are not met. After creating a file from a Vista client, the permissions are 644, no matter what I 'force'. Has anyone encountered a similar issue, and what could be the cause of this?

best regards, André
 
Old 03-17-2009, 06:08 AM   #2
chitambira
Member
 
Registered: Oct 2008
Location: Fife
Distribution: RHEL, Centos
Posts: 373
Blog Entries: 1

Rep: Reputation: 49
Quote:
'force create mode = 664'
The modes in this parameter are bitwise 'OR'ed onto the file mode after the mask set in the create mask parameter is applied.
Note that default for create mask is 744. What is your set to? If you do not have it, its best to configure it and put create mask = 764
 
Old 03-25-2009, 06:34 AM   #3
hillersa
LQ Newbie
 
Registered: Mar 2009
Posts: 2

Original Poster
Rep: Reputation: 0
Hello chitambira,

thank you for your answer, unfortunetaly I was busy with another project last week, so I am replying a little late.

My directory mask is now set to 775' and my create mask is set to '664', which solved the problem i guess,

best regards, André

Last edited by hillersa; 03-25-2009 at 06:49 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to avoid force check of root filesystem while booting RHEL frcrce08 Linux - Software 1 02-02-2009 10:40 AM
how to force monitor into 120hz mode? hedpe Linux - Software 1 10-10-2008 06:25 AM
How to force write cache mode on aacraid? pofcorn Linux - Hardware 1 03-21-2007 08:19 AM
Need to force usb1.1 mode for printer. chaumurky Linux - Hardware 4 03-17-2006 04:38 PM
Samba - Create Mask/Mode anilnatha Linux - Software 8 07-26-2004 06:27 PM


All times are GMT -5. The time now is 03:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration