LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 12-04-2008, 01:31 PM   #1
pentode
Member
 
Registered: Dec 2005
Location: Oregon
Distribution: Debian Testing
Posts: 488

Rep: Reputation: 38
Question [Solved] Rsnapshot backup of Windows client - name resolution problem


I'm testing out doing backups of a Windows laptop to a Linux server using rsnapshot. I've got the pieces in place and and can connect rsync from the server to the laptop - but only if I use the (local) IP address of the laptop. The computer name is not being resolved apparently.

We have been using DHCP from our router for our laptops and using our ISP for DNS.

Am I correct in thinking that we need to go to fixed IP addresses or start running some type of DNS/DHCP software on the server in order to get this to work consistently?

Or is there some other way to get the name resolved? Samba can find the machines by name because we have WINS running (on the old Windows 2000 Server I'm trying to get rid of), but I don't think rsync is going to work with a Samba share - or least I haven't been able to figure it out.

Going to fixed IP addresses seems the simplest solution at this point - or am I missing something.

Thanks,

Dave

Last edited by pentode; 12-05-2008 at 04:05 PM. Reason: Problem Solved
 
Old 12-04-2008, 02:59 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Naturally your ISP isn't going to provide name resolution for your private network. The easiest thing to do on a small network is to use the /etc/hosts file to associate your private network addresses with your LAN computers. Then make sure that the line in the /etc/nsswitch.conf file puts name resolution priority to the local hosts file before dns. The line in that file should look like this.
Code:
hosts:          files dns
That line might have other entries in addition to the two that I have listed. The important thing is that the "files" keyword is before the "dns" keyword.

If you have more than let's say 100 servers on your LAN you may want to set up a DNS server. Since you haven't needed one yet you probably still don't need one.

Last edited by stress_junkie; 12-04-2008 at 03:01 PM.
 
Old 12-04-2008, 03:14 PM   #3
pentode
Member
 
Registered: Dec 2005
Location: Oregon
Distribution: Debian Testing
Posts: 488

Original Poster
Rep: Reputation: 38
Thanks. I did think of the hosts file, but since we are using DHCP for the laptops, I figured that would fail eventually when the IP address changed. The simple solution seems to be to configure the laptops for fixed IP address on our LAN, instead of DHCP.

No, I don't really want a DNS server. But I'm really looking forward to getting rid of this Windows 2000 Server that is locking up at least once a day.
 
Old 12-04-2008, 04:30 PM   #4
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Quote:
Originally Posted by pentode View Post
Thanks. I did think of the hosts file, but since we are using DHCP for the laptops, I figured that would fail eventually when the IP address changed. The simple solution seems to be to configure the laptops for fixed IP address on our LAN, instead of DHCP.
The laptops and desktop machines should not need a fixed address. Only servers need a fixed address. Or I should say that computers that accept inbound connections need a fixed address. I'm thinking of machines that frequently share desktop logins. Otherwise DHCP should be fine for any machine that rarely or never needs to accept inbound connections.

Last edited by stress_junkie; 12-04-2008 at 04:33 PM.
 
Old 12-04-2008, 05:04 PM   #5
pentode
Member
 
Registered: Dec 2005
Location: Oregon
Distribution: Debian Testing
Posts: 488

Original Poster
Rep: Reputation: 38
Yes, that has been working well for a long time. But when trying to backup the laptops using Rsync, the computer name is not resolved because there is no DNS server for it. Rsync works using the laptop's current IP address, but that could change. Samba works using WINS. But it appears Rsync requires DNS.
 
Old 12-05-2008, 04:07 PM   #6
pentode
Member
 
Registered: Dec 2005
Location: Oregon
Distribution: Debian Testing
Posts: 488

Original Poster
Rep: Reputation: 38
In case anyone is interested, I solved the name resolution problem by modifying /etc/nsswitch.conf.

For the "hosts" entry, just needed to add wins to the list (after files and before DNS). Works as long as there is a WINS server on the LAN.

Cheers,

Dave
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rsnapshot and Backup Strategy Woodsman Slackware 2 04-28-2008 10:48 PM
problem setting up rsnapshot Mehmet Karatay Linux - Software 1 01-31-2008 03:53 AM
Using rsnapshot to make a system backup Transition Slackware 1 03-21-2005 09:23 PM
Rsync Backup From Windows To Linux Problem sectrean Linux - Networking 0 10-18-2004 04:11 PM
SFTP + Windows Client problem killahwave Linux - Networking 1 06-22-2004 12:38 PM


All times are GMT -5. The time now is 07:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration