-   Linux - Server (
-   -   RHEL 6 packagekit network proxy popup (

xion824 10-07-2011 05:56 AM

RHEL 6 packagekit network proxy popup
Hi all. On a couple of my RHEL 6.1 servers, I get a popup message, under all accounts, when logging in graphically. This popup gives the following message:

Authentication is required to set the network proxy for downloading packages
An application is attempting to perform an action that requires privileges. Authentication as the super user is required to perform this action.
The details window shows:
Role: unknown
Action: org.freedesktop.packagekit.system-network-proxy-configure

This occurs every time someone logs in. No matter how many times the root password has been supplied. I have this problem on 3 out of 5 systems. Each built exactly the same. Two are 32-bit, three are 64-bit. The only recommended fix I've found is to add "proxy=http://name:port" to the end of the yum.conf file (obviously replacing with the actual info). This does not work for me. We are not running a proxy.

Anyone have any ideas on how to fix this? This has me stumped. Thanks!

netnix99 10-08-2011 08:31 PM


I have not seen this error personally, but it sounds like the RHN registration was told to point to a proxy server for updates. to fix, open a terminal window, su to root, and type rhn_register (you will need your credentials for the Red Hat Network here). If it prompts you and says that a profile already exists, select to continue anyway. Step through the process and connect directly not through a proxy (I think this is the 2nd or 3rd screen).

xion824 10-08-2011 11:30 PM

We cannot connect to RHN, as we are on a dark net. Aside from that, the systems are already configured for direct. We have a YUM server built that all these systems point to. Which works correctly.

michas100 03-17-2015 01:52 PM

I give you a workaround simply go to gnome-session-properties and uncheck PackageKit tell us if its help. regards Michal

All times are GMT -5. The time now is 10:59 PM.