LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 07-20-2007, 02:02 PM   #1
rhugga
LQ Newbie
 
Registered: Jul 2007
Posts: 5

Rep: Reputation: 0
RHEL 5: Where to enable X server tcp port 6000?


Normally this is done in /etc/sysconfig/displaymanager. I cannot find where to configure X server to allow connections on port 6000.

YES I KNOW THIS IS INSECURE. NO IPTABLES IS NOT RUNNING.

Thanks for any info.
CC
 
Old 07-20-2007, 03:45 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
this generally changes per distro and login manger, please try to provide more useful information. under fedora this would be via running gdmsetup or editing /etc/gdm/custom.conf
 
Old 07-21-2007, 02:16 PM   #3
mhm
Member
 
Registered: Oct 2006
Distribution: RHEL, FC
Posts: 56

Rep: Reputation: 15
Hey,
In RHEL4 there is a command:
$gdmconfig, under security tab uncheck the check box that said 'always disallow tcp connection ........' and under the XDMP (sorry if I missed the spelling) check the only check box, go to black screen console and do $ killall gdm-binary....

I hope this helps

Regards
Mhm
 
Old 07-21-2007, 02:54 PM   #4
rhugga
LQ Newbie
 
Registered: Jul 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by mhm
Hey,
In RHEL4 there is a command:
$gdmconfig, under security tab uncheck the check box that said 'always disallow tcp connection ........' and under the XDMP (sorry if I missed the spelling) check the only check box, go to black screen console and do $ killall gdm-binary....

I hope this helps

Regards
Mhm
This box has no head, do you happen to know what config files the above gui elements were touching?

Thx
CC
 
Old 07-21-2007, 04:10 PM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
i already told you this...
 
Old 07-22-2007, 09:36 AM   #6
rhugga
LQ Newbie
 
Registered: Jul 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by acid_kewpie
i already told you this...
Sorry, by my asking the other dude was implying that /etc/gdm/custom.conf wasnt working. Ill be more clear next time. The man page also points to another file that doesn't even exist.
 
Old 07-22-2007, 12:49 PM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
well under rhel5 it should be the same place. i'm not honestly *that* sure how gdm will run without a local X server... there actually may be something like /etc/sysconfig/gdm or something, which is a directory that redhat have been centralizing around more and more, especially for boot services. i was also originally expecting to tell you to look at /etc/X11/gdm or similar, which is where i always thought the config file lived, but i only checked on fedora 7, so redhat 5 with it's older strucutre may well still have it.

Last edited by acid_kewpie; 07-22-2007 at 12:52 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X11 Using TCP port 6000 AMMullan Linux - Security 4 04-12-2010 06:03 PM
OpenSuse 10 - X server doesn't appear to listen on tcp:6000 The MCP Suse/Novell 5 04-05-2006 01:11 PM
TCP Port 53 Open - How to enable UDP 53? stardotstar Linux - Networking 6 03-16-2005 05:49 AM
X Server port 6000 not starting Ynog Fedora 0 06-14-2004 04:09 PM
close port 6000/tcp 515/tcp SchwipSchwap Linux - Newbie 1 09-12-2002 09:24 AM


All times are GMT -5. The time now is 09:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration