LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 06-21-2010, 01:33 AM   #1
czezz
Member
 
Registered: Nov 2004
Location: Poland/Warsaw
Distribution: Slackware/Solaris
Posts: 571

Rep: Reputation: 30
restore systemu form /dev/hda to /dev/sda


I have restored system form backup (tar).
It is not a first time Im doing that - and it always works.

However this time I want to restore system which was working on device /dev/hda to a /dev/sda.
At the last stage of the procedure, I have mounted restoret root file system, and change root to it. Then change /dev/hda to /dev/sda in /etc/vfstab and /etc/lilo.conf.
When I executed "lilo" command I received this error:
Code:
fatal: raid_setup: stat("/dev/hda")
What did I forgot to do ? Is that possible to restore system like that ?
Kernel has support for both IDE and SATA devices. This is Slackware 12.2
 
Old 06-21-2010, 05:08 PM   #2
czezz
Member
 
Registered: Nov 2004
Location: Poland/Warsaw
Distribution: Slackware/Solaris
Posts: 571

Original Poster
Rep: Reputation: 30
Well... the answer is: block devices (these is /dev) need to be created/recreated. This way:

Code:
# mknod /dev/hda b 3 0
# mknod /dev/hda1 b 3 1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/dev/sda (SATA) devices detected as /dev/hda Please help ayvazyan Linux - Newbie 2 01-23-2010 02:17 AM
Is it /dev/hda or /dev/sda? in opensuse 10.3 BK2 Suse/Novell 3 11-29-2007 08:13 PM
Linux 2.6.21.5 to 2.6.22.3: /dev/sda becomes /dev/hda CalcAndCoffee Linux - Laptop and Netbook 10 08-26-2007 10:08 AM
Install lilo on external drive (/dev/sda), then boot as INTERNAL (/dev/hda)? slackware-elf Slackware 3 08-18-2007 04:51 PM
Where is my HD? - not /dev/hda or /dev/sda ?? BrianK Linux - Hardware 11 04-24-2007 05:35 PM


All times are GMT -5. The time now is 08:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration