LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   RedHat 11 - Configuring SAMBA / shares (http://www.linuxquestions.org/questions/linux-server-73/redhat-11-configuring-samba-shares-736114/)

JonathanWexler 06-27-2009 07:18 PM

RedHat 11 - Configuring SAMBA / shares
 
I am (trying to) install RedHat v11, and am having no luck getting NETBIOS names set up, let alone file sharing with Windows/Linux computers on my network. (I do not think I was entirely insane to try this - a couple of years ago, I got this all working on Fedora 6)

So, what have I done
1) Installed it
2) edited \etc\samba\smb.conf for workgroup name, netbious name
WINS server on, no DNS resolution
3) I can get to the Internet, so I know the router it is connected to is giving it a good IPv4 address (but the router log does not show the NETBIOS name for the unit, which cannot be a good thing)

I can ping to or from the unit to other computers on the network, but the name resolution stuff does not work in either direction.

Looking at Administration ... Services, I do not see an entry for SAMBA, smbd or anything else relevant .... it was there in Fedora 6.


Looking at the smb.conf comments, there is a mention that the SELINUX characteristics for the folder I wish to share needs some "samba-user" notation set, but I do not see any way to set it via the context menu for the folder.

Any help appreciated.

Jonathan

armanox 06-27-2009 08:57 PM

I am going to assume you mean Fedora 11, as there was no Red Hat 11....

Check to make sure that all of the samba packages are installed. Also, the file to start the service should be /etc/init.d/smb - you could try starting it from the command line as root
Code:

# /etc/init.d.smb start
If the samba packages are not all installed (which I don't think Fedora does by default), then that command will fail.

JonathanWexler 06-28-2009 10:16 AM

better, but not done
 
Thanks for the advice. yum install samba got me samba installed, which I was able to start but name resolution still fails.

Specifically, the router is not seeing the NETBIOS name when its DHCP server assigns an address.

From the LINUX box, I can
a) access the Internet
b) get name resolution for machines not on the LAN (ping www.yahoo.com works)
c) ping LAN address by IPv4

but I cannot ping names on the LAN

From other computers on the LAN, I can ping the LINUX box by IPv4, but not by NETBIOS name.

Thanks

Jonathan

PS. You are correct, I installed Fedora 11, not RedHat 11

arty 06-28-2009 01:30 PM

if smbd is up and running try to connect to it
forget the name and try the ip
on client"s side do: START,RUN,type: \\ip_of_smb_server
if it doesn't work you have to check connectivity with the linux machine
try to ping it's ip
if you can ping double check if smbd is running
if you are sure you see the process running
check if it's listening on the correct port
try "netstat -ln | grep 445"

JonathanWexler 06-28-2009 07:15 PM

What is the procedure for "connecting to smbd"

the UI for Administration ... Services shows (for each of smd and nbd) "Enabled" and "Running" - but,
1) the Administration ... Services ... does not show "Samba' as an option (as it does in Fedora 6)
ii) the System Monitor ... Processes tab does not show either smbd or nmbd as running processes (should it?)

the NSTAT command exits after a single line which reads

tcp 0 0 :::445 :::% LISTEN

Thanks
Jonathan

arty 06-30-2009 07:56 AM

open an explorer windows within windows and type at address bar \\ip_of_smb_server

JonathanWexler 06-30-2009 10:02 PM

Okay, I tried //192.168.0.109 in Firefox and got "file not found"

On a Windows box on the LAN I tried (on both Windows Explorer and Internet Explorer) //192.168.0.109 //192.168.0.109:445 \\192.168.0.109
and \\192.168.0.109:445 - all of these produced errors sounding like "can't connect".

Looking at other posts, I tried

chkconfig --list
which showed both smb and nmb are "on" at levels 2345 (whatever that
means)

smbclient -L localhost returns "'client lanman auth' is disabled"


All times are GMT -5. The time now is 05:58 AM.