LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 02-27-2012, 12:31 PM   #1
velvetbulldozer
LQ Newbie
 
Registered: Feb 2012
Posts: 14

Rep: Reputation: Disabled
Raid: Mdadm error


Hi guys,

I have a 1TB raid5 array of 3 disks running on Centos 6.2, and one disk got lost.(this a test bench of 3 usb hd)

When I try to reconnect the missing drive I get the error: ¨Error adding spare: mdadm exited with exit code 2: mdadmption --force not valid in manage mode¨

It seems like mdadm thinks I am about to add a spare, but I am not.

I am using Red Hat disk utility 2.30.1. The array is working with clients writing to it.

Any suggestions how to solve this?

Thanks,

Dan
 
Old 02-27-2012, 01:30 PM   #2
troop
Member
 
Registered: Feb 2010
Distribution: gentoo, arch, fedora, freebsd
Posts: 379

Rep: Reputation: 96
You should remove failed disk from array. mdadm /dev/mdX -r /dev/sdX
Then re-add.
 
Old 02-27-2012, 01:43 PM   #3
velvetbulldozer
LQ Newbie
 
Registered: Feb 2012
Posts: 14

Original Poster
Rep: Reputation: Disabled
no such device.....

Thanks.
I get the following error:

¨mdadm /dev/md127 -r /dev/sdc1
mdadm: hot remove failed for /dev/sdc1: No such device or address¨

Any ideas?

Quote:
Originally Posted by troop View Post
You should remove failed disk from array. mdadm /dev/mdX -r /dev/sdX
Then re-add.
 
Old 02-28-2012, 03:15 AM   #4
troop
Member
 
Registered: Feb 2010
Distribution: gentoo, arch, fedora, freebsd
Posts: 379

Rep: Reputation: 96
post mdadm -D /dev/md127 here
 
Old 02-28-2012, 10:02 AM   #5
velvetbulldozer
LQ Newbie
 
Registered: Feb 2012
Posts: 14

Original Poster
Rep: Reputation: Disabled
array failed

After reboot i managed to attach a new drive. During the re-sync process it lost the new drive again and the whole array became extremly slow (200Kb read/write). I have a raid one in the lab now with a new error. I make a new post.
Thanks.
Quote:
Originally Posted by troop View Post
post mdadm -D /dev/md127 here
 
  


Reply

Tags
attachment, drive, mdadm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MDADM error: Help creating a RAID 1 RAM disk abidbodal Linux - Newbie 3 04-10-2011 12:33 PM
Broken raid 5 (11 drives in mdadm) -- data recovery/raid reconstruction needed -- ple jml48197 Linux - Server 4 07-27-2010 12:57 PM
Dell/Intel ICH7 soft-RAID and mdadm raid-level mistake PhilipTheMouse Linux - General 0 03-14-2009 05:59 PM
RAID mdadm - Sending E-Mails on RAID Failure? rootking Linux - General 1 12-25-2007 03:59 AM
Use mdadm create raid-5 with parity error Friarchen Linux - Software 1 10-08-2004 02:12 AM


All times are GMT -5. The time now is 08:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration