LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 11-14-2008, 08:18 PM   #1
vischa
LQ Newbie
 
Registered: Nov 2008
Location: Colorado
Distribution: Fedora Core 9
Posts: 5

Rep: Reputation: 1
Angry PXE Server is giving the public IP instead of private IP


First off I only have one NIC

Here is a link to the error please also read: http://i208.photobucket.com/albums/b...k/PXEerror.jpg

I have a server (to be labeled 'games') that has no CD-rom or Floppy, only way to install is through PXE.

I have another server named 'web', running the DHCP for my network, I configured it to push an image of Fedora Core 9.

When I do the PXE boot on the server 'games' it does receive an IP, as well as the subnet mask, but the DHCP IP is showing up as my public IP instead of the internal of 172.17.6.4 (Reserved by Cisco, but still a private IP), and the TFTP push ends up timing out/failing ('PXE-E32: TFTP open timeout'), I have tried opening the public ports just to see if it would work and it didn't. When I disable my internet connection I get an error that says:

No dhcp offers or proxydhcp offers were received.

Which is really throwing me for a loop, since 'web' is the only dhcp server on the network.

Here is my dhcpd.conf file, that I used with Fedora Core 6 and recently upgrade to fc9, I have looked to see if any one else has had this problem, but so far I have not seen it. If there is an answer, feel free to give me a link and call me newbie. Though I did try, for a week.

*Note* I am using a dynamic domain, "vischa.no-ip.org" for various services, and the PXE server is setup as "web.vischa.no-ip.org" also the lines containing "server-name" were originally "web.vischa.no-ip.org" and I changed them to try and correct this problem.


Code:
allow unknown-clients;
ddns-rev-domainname "vischa.no-ip.org";
server-name "172.17.6.4";
use-host-decl-names on;
#option time-servers 192.168.0.114;
option broadcast-address 172.17.6.255;
option subnet-mask 255.255.255.0;
option routers 172.17.6.1;
# File with key we shall use to securely update zone files
###########################################################
include "/etc/named.keys";

# Our server is authority
#########################################################
server-identifier vischa.no-ip.org;
authoritative;

# Fedora 's DDNS Zone 
zone vischa.no-ip.org. {
	primary 172.17.6.4;
	key DHCP_UPDATER;
	}

default-lease-time 86400;
max-lease-time 172800;

option domain-name "vischa.no-ip.org";
option domain-name-servers 172.17.6.4, 68.87.85.98, 68.87.69.146;
#option domain-name-servers 172.17.6.1;

allow client-updates;
ddns-domainname "vischa.no-ip.org";
ddns-updates on;
ddns-update-style interim;

# Declaration of network properties ( range ... )
# Fedora 's DDNS Zone

subnet 172.17.6.0 netmask 255.255.255.0 {
	max-lease-time 172800;
	default-lease-time 86400;
	next-server 172.17.6.4;
	authoritative;
	allow client-updates;
	allow unknown-clients;
	ddns-updates on;
	ddns-rev-domainname "vischa.no-ip.org";
	ddns-domainname "vischa.no-ip.org";
	server-name "172.17.6.4";
	option tftp-server-name "172.17.6.4";
	range dynamic-bootp 172.17.6.220 172.17.6.230;
	range 172.17.6.50 172.17.6.150;
	option root-path "172.17.6.4:/tftpboot/";
	filename "pxelinux.0";

	zone vischa.no-ip.org {
		primary 127.0.0.1;
		key DHCP_UPDATER;
		}

	zone 6.17.172.in-addr.arpa. {
		primary 127.0.0.1;
		key DHCP_UPDATER;
		}
	option subnet-mask 255.255.255.0;
	option routers 172.17.6.1;

	one-lease-per-client on;
	group {
		ddns-rev-domainname "vischa.no-ip.org";
		ddns-domainname "vischa.no-ip.org";
		server-name "172.17.6.4";
		max-lease-time 172800;
		default-lease-time 86400;
		allow client-updates;
		allow unknown-clients;
		ddns-updates on;
		use-host-decl-names on;
		}

	host acidburn {
		hardware ethernet 00:01:6C:BB:06:22;
		fixed-address 172.17.6.21;
	}

	host stephanie {
		hardware ethernet 00:01:6C:33:E3:D2;
		fixed-address 172.17.6.20;
	}
	host games {
		hardware ethernet 00:06:5b:04:26:e9;
		fixed-address 172.17.6.3;
	}

}
I have tried commenting out everything that refers to my dynamic IP, didn't work, tried commenting out the router information, and it still passes the public IP, also I only have one NIC, and it is connected to a switch quick map of network.

Inter-tubes--Comcast---> Sonicwall(172.17.6.1/24)--->Switch--->Servers and Clients

PXE and DHCP 'web'(172.17.6.4/24)<--->Switch<---> Server 'games'(172.17.6.3/24)
Class C Network


Any other ideas, or comments would be welcome.
Thanks for helping.

Vischa

Last edited by vischa; 11-14-2008 at 11:51 PM. Reason: Adding Screen cap
 
Old 11-16-2008, 02:03 PM   #2
tmick
Member
 
Registered: Jun 2005
Location: Riverdale, Utah
Distribution: Debian Jessie
Posts: 146

Rep: Reputation: 15
Try following this:
http://www.opensourcehowto.org/how-t...a-install.html
it sounds like the DHCP server isn't configured on the PXE server correctly.
Also ensure the kickstart file is directed to your PXE server
 
Old 11-16-2008, 07:33 PM   #3
Shinigami101
LQ Newbie
 
Registered: Nov 2008
Posts: 7

Rep: Reputation: 0
make sure that you have the NIC set up correctly in VMware player it could be you have it set on VMnet1 or so on (one of the ones that uses the Virtual network Editors DHCP server.)

You want to change the Network Adapter to "Bridged"

hope this helps
 
Old 11-17-2008, 12:26 AM   #4
vischa
LQ Newbie
 
Registered: Nov 2008
Location: Colorado
Distribution: Fedora Core 9
Posts: 5

Original Poster
Rep: Reputation: 1
The VMware player was just to get a screenshot, I have already looked at the link that you sent I even try starting my dhcpd.conf over but it still gave the public IP instead of the private, thanks for the link though. Also, it is not even getting to the kickstart, I haven't written a auto install script yet. I want to get the pxe working first.

Last edited by vischa; 11-17-2008 at 12:29 AM.
 
Old 11-17-2008, 10:47 PM   #5
tmick
Member
 
Registered: Jun 2005
Location: Riverdale, Utah
Distribution: Debian Jessie
Posts: 146

Rep: Reputation: 15
Quote:
Originally Posted by vischa View Post
I have already looked at the link that you sent I even try starting my dhcpd.conf over but it still gave the public IP instead of the private, thanks for the link though.I haven't written a auto install script yet. I want to get the pxe working first.
Actually this link is better: http://linux-sxs.org/internet_serving/pxeboot.html
 
Old 12-02-2008, 10:58 AM   #6
shantanu_gadgil
LQ Newbie
 
Registered: Dec 2008
Posts: 6

Rep: Reputation: 0
For me disabling the firewall DID NOT help.

What did the trick was:
1. Keep the DHCP (dhcpd) and the TFTP (xinetd + tftp) server on the same machine.
2. use the DHCP directive "next-server" to point to the same machine.

What I have also observed is that this is related to the LAN card...
It works OK for an Intel card but the timeout thing happens for a RTL 8139 chipset card.

Maybe using dnsmasq might give people different results ???

Regards,
Shantanu
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH with passwordless public/private key not working on another account on server infocom Linux - Server 14 12-27-2010 05:09 AM
DNS Server (bind9) works on the private network but not in the public one! wjleon Linux - Networking 26 01-24-2009 08:14 PM
1 public server, 1 private server with a Cisco ASA5505 inbetween, is this hard to do? abefroman Linux - Networking 12 04-10-2008 09:39 AM
public IP & private IP munna_dude Linux - Networking 2 07-10-2007 12:58 AM
public vs private ip emailssent Linux - Networking 2 09-28-2004 02:11 AM


All times are GMT -5. The time now is 01:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration