LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 11-25-2009, 03:05 AM   #1
ramu.kavati
LQ Newbie
 
Registered: Nov 2009
Posts: 5

Rep: Reputation: 0
PXE remote boot issue with Intel gigabit ET Dual port server adapter


Hi,

I am trying to verify pxe boot of SLES 11 via Intel gigabit ET Dual port server adapter.

I have setup dhcp server, tftp server, NFS (exported /tftpboot to diskless host with proper permissions) and /tftpboot/pxelinux.cfg/default on a machine. When I try to remote install on a diskless host, it could not find harddisk. I had to manually mount /tftpboot as "/ " via NFS, then installation went fine. At the end, when it asked for reboot, I have changed /tftpboot/pxelinux.cfg/default with the options root=/dev/nfs nfsroot=nfs://<IP>/tftpboot. But diskless throws an error "unable to mount nfs://<IP>/tftpboot". Can you please let me know if I am missing anything in the above setup.



Thanks & Regards,

Ramu
 
Old 11-25-2009, 07:49 AM   #2
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,395
Blog Entries: 2

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
If you are trying to boot to an NFS root filesystem, then the kernel must be built with NFS root support. Is this what you are trying to do?
--- rod.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pxe server issue ,why do i need to enable port-fast alix123 Linux - Server 4 04-03-2014 07:30 AM
PXE remote boot issue with Intel gigabit ET Dual port server adapter ramu.kavati Linux - Networking 1 11-25-2009 04:28 AM
PXE remote boot issue with Intel gigabit ET Dual port server adapter ramu.kavati Linux - Software 0 11-25-2009 03:04 AM
Fedora 11 KDE won't use intel 82540em gigabit ethernet adapter newbie to linux Linux - Networking 8 07-12-2009 06:58 PM
Intel e1000 gigabit adapter with RH 7.2 dulli1 Linux - Networking 3 02-14-2003 08:45 AM


All times are GMT -5. The time now is 04:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration