LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 04-27-2009, 05:03 PM   #1
efilnei
LQ Newbie
 
Registered: Apr 2009
Posts: 10

Rep: Reputation: 0
PXE-E32 tftp open timeout


Hi, i'm configuring a LTSP server with CentOS 5.3

I have all installed (dhcp, tftp, nfs and xdmcp). I have to run the clients with PXE.This is my dhcpd.conf:

Code:
# dhcpd.conf

ddns-update-style             ad-hoc;

option subnet-mask            255.255.255.0;
option broadcast-address      192.168.0.255;
option routers                192.168.0.132;
option domain-name-servers    192.168.0.132;
option domain-name            "your_domain.org";   # You really should fix this
option option-128 code 128 = string;
option option-129 code 129 = text;


get-lease-hostnames           true;

next-server                   192.168.0.132;
option root-path              "192.168.0.132:/opt/ltsp/i386";

subnet 192.168.0.0 netmask 255.255.255.0 {
    range   192.168.0.100   192.168.0.199;
    if substring (option vendor-class-identifier, 0, 9) = "PXEClient" {
        filename "/lts/2.6.9-ltsp-3/pxelinux.0";
    }
    else{
        filename "/lts/vmlinuz-2.6.9-ltsp-3";
    }
}
I think is all ok. When i run the clients, they get a IP from the DHCP server, but when they try to get the kernel, TFTP fails and give this error:

PXE-E32 tftp open timeout

I have tftp installed, and when i run "ltspcfg" i can see tftp is running, but i don't know what's the problem

Please help Thanks! Sorry for the english, is not very good, hehe
 
Old 04-29-2009, 01:02 AM   #2
asprakash
Member
 
Registered: May 2006
Location: Chennai, India
Posts: 74
Blog Entries: 3

Rep: Reputation: 18
Hi,
Yesterday, I am also faced the same problem and found solution.
* Be ensure that your tftp is running before you boot your client.
I found that $/etc/init.d/tftpd-hpa start has no effect until I modified the file /etc/default/tftpd-hpa. Just replace YES instead of NO in the first line. It should be like, RUN_DAEMON="yes"

* Now run $/etc/init.d/tftpd-hpa start. You will get the response.
* Now check your client.
Hint : Try "cat -f /var/log/syslog" in ur terminal. You will get the info like,
Apr 29 11:30:15 rtlinux-desktop dhcpd: DHCPDISCOVER from 00:1c:c0:6e:da:4a via eth2
Apr 29 11:30:16 rtlinux-desktop dhcpd: DHCPOFFER on 192.168.1.49 to 00:1c:c0:6e:da:4a via eth2
Apr 29 11:30:18 rtlinux-desktop dhcpd: DHCPREQUEST for 192.168.1.49 (192.168.1.1) from 00:1c:c0:6e:da:4a via eth2
Apr 29 11:30:18 rtlinux-desktop dhcpd: DHCPACK on 192.168.1.49 to 00:1c:c0:6e:da:4a via eth2
Apr 29 11:30:18 rtlinux-desktop in.tftpd[32186]: connect from 192.168.1.49 (192.168.1.49)


-Prakash.
 
Old 04-29-2009, 04:47 PM   #3
efilnei
LQ Newbie
 
Registered: Apr 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Hi. Thanks for answer. I was trying that you say but:

i don't have script "/etc/init.d/tftp-hpa"
i don't have script "/etc/init.d/tftp

And

i don't have file /etc/default/tftpd-hpa

I have CentOS 5.3 :S ¿What's the problem? I have installed tftp package
 
Old 04-29-2009, 05:56 PM   #4
efilnei
LQ Newbie
 
Registered: Apr 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Hi again. I be searching (again) from Google the same problem. I have found to many posts, but no luck...

Too many people said that the problem is the firewall, and i had to open some ports (69); maybe tftp was blocked, but no is the problem...
 
Old 11-30-2012, 08:14 AM   #5
miguelangeljma
LQ Newbie
 
Registered: Sep 2012
Posts: 9

Rep: Reputation: Disabled
How con configure teh tftp

Quote:
Originally Posted by efilnei View Post
Hi. Thanks for answer. I was trying that you say but:

i don't have script "/etc/init.d/tftp-hpa"
i don't have script "/etc/init.d/tftp

And

i don't have file /etc/default/tftpd-hpa

I have CentOS 5.3 :S ¿What's the problem? I have installed tftp package
On CentOS systems the tfpt daemon is called xinetd. You need to configure the tftp file inside /etc/xinetd.d and change to NO in the conf file where it says DISABLE.

Once you do that, your tftp server will be working fine.

Good luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PXE-E32 TFTP open timeout maxchock Linux - General 11 09-12-2013 07:52 AM
Error "TFTP open timeout" Ogi Linux - Networking 5 10-07-2009 09:16 AM
PXE-TFTP Installation Server dipuasks Linux - General 6 12-04-2008 01:44 AM
pxe-e32 tftp open time out error ncsuapex Linux - Networking 3 04-24-2008 04:03 PM
PXE TFTP thin client paul_mat Linux - Networking 2 01-19-2006 06:41 AM


All times are GMT -5. The time now is 10:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration