LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 05-22-2008, 05:04 PM   #1
nutnut
Member
 
Registered: Feb 2005
Location: UK
Distribution: Gentoo
Posts: 86

Rep: Reputation: 15
Unhappy PureFTPd (Debian pure-ftpd-mysql) - Specifying Passive Mode Ports?


Hi,

I've just installed/configured PureFTPd on my Debian server (the pure-ftpd-mysql package) with plenty of fun and games along the way, but I'm having some trouble specifying the passive mode ports I want it to use.

I can't find the option in any of the config files, so I'm now thinking I'll need to edit the start-stop-daemon line in the init script, which is:

start-stop-daemon --start $SSDAEMONLOGOPTS --pidfile /var/run/pure-ftpd/pure-ftpd.pid --exec $WRAPPER -- $SUFFIX

Based on what I've read in the man page for start-stop-daemon, I assumed that I could just pop -p40000:40050 on the end of that and it would be passed to the program when it was started.

Unfortunately this doesn't seem to be the case and I'm somewhat at a loss.

Perhaps I'm simply missing a config file somewhere, but I've been searching around for a fair while and I can't seem to shed any light on the issue. Hopefully I'll have more luck here !

Thanks in advance,
James
 
Old 01-06-2009, 08:33 AM   #2
mogie
LQ Newbie
 
Registered: Jan 2009
Posts: 1

Rep: Reputation: 0
I'm on to this setup this very moment. I'm still having some problems with the passive port range on LAN and WAN. I already have a server working with passive mode with pure-ftpd, but it's hard to figure out what the problem is when I've already copied all the options from this server.

You know that the easiest way to configure your pure-ftpd is to use the conf/ folder and save files here?


try these options:

-p 41000:41100 -- > specifies the portrange. Save the file as /etc/pure-ftpd/conf/PassivePortRange

It is possible you'll need to specify you LAN IP for your router if u use one. I've set mine to:
-P 192.168.1.2
u simply save the value "192.168.1.2" in the file /etc/pure-ftpd/conf/ForcePassiveIP

Remember the "-p" and "-P" is NOT to be included in the configfiles (if u use them, u need them in your startupscript ofcourse)

Add-on: I do remember when troubling with these settings, that resetting my Ubuntu server worked out. Not sure why, but I remember it did.
/etc/init.d/pure-ftpd restart didn't update my settings for some reason. Worth a try

Last edited by mogie; 01-06-2009 at 08:36 AM.
 
Old 05-19-2009, 12:52 PM   #3
cfriisha
LQ Newbie
 
Registered: May 2009
Posts: 2

Rep: Reputation: 0
This was a great help mogie. I have just been installing ISPConfig and had to be certain about the ftp-data port range. I pretty much followed your idea on the Ubuntu 9.04 server box:

print "60010 60030" > /etc/pure-ftpd/conf/PassivePortRange
/etc/init.d/pure-ftpd-mysql restart

and during the restart the port range was confirmed :-)
 
Old 09-29-2009, 11:12 AM   #4
ustoopia
LQ Newbie
 
Registered: Feb 2005
Posts: 1

Rep: Reputation: 0
I also installed ISPConfig 3 and was trying to find how to set the passive port range. This topic helped me configure it. I installed it on ubuntu 9.04. I already had created the file PassivePortRange in /etc/pure-ftpd/conf/ so all i did was:

echo "40110 40210" > /etc/pure-ftpd/conf/PassivePortRange

/etc/init.d/pure-ftpd-mysql restart
 
  


Reply

Tags
passive, pureftpd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pure-ftpd-mysql activates pure-ftpd zvikamer Linux - Software 2 03-01-2008 01:11 PM
Pure-Ftpd and MySql and Fedora core 5 olva Fedora 1 04-30-2006 08:45 AM
Pure-ftpd-mysql + Sarge nestor10 Linux - Software 1 01-26-2005 09:06 AM
pure-ftpd and mysql dominant Linux - General 1 01-11-2005 03:33 AM
How to have passive mode off by default in wu-ftpd alisajjad Linux - Networking 0 07-30-2003 07:34 AM


All times are GMT -5. The time now is 01:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration