LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 11-06-2006, 11:11 AM   #1
jaxen
LQ Newbie
 
Registered: Nov 2006
Location: UK
Distribution: Debian 3.1 (Stable Sarge)
Posts: 3

Rep: Reputation: 0
PureFTP user accounts


Hi,

I'm trying to set up an ftp user-accounts for each of my shell users. As far as I was aware, this was as easy as installing an ftp daemon, running it and logging in as one of the shell users.

Well I can do the first two things, but unfortunately I cant login as ANY of the shell users, not even root. I have tried using both proftpd and pureftpd but none have been able to do this. I dont want to create a virtual user, I just want every shell user to have access to their /home/username/ directory and for it to be chrooted on login.

What am I missing here?
 
Old 11-06-2006, 11:44 AM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Is FTP even running or listening? What errors are you recieving, does it ever prompt for a username/password?
 
Old 11-06-2006, 11:56 AM   #3
jaxen
LQ Newbie
 
Registered: Nov 2006
Location: UK
Distribution: Debian 3.1 (Stable Sarge)
Posts: 3

Original Poster
Rep: Reputation: 0
I can see the server daemon running, and I can connect both from the server and externally.

Heres what happens when I issue the command 'ftp localhost'..

Code:
s15229711:~# ftp localhost
Connected to localhost.localdomain.
220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
220-You are user number 1 of 50 allowed.
220-Local time is now 17:02. Server port: 21.
220-This is a private system - No anonymous login
220 You will be disconnected after 15 minutes of inactivity.
Name (localhost:root): xxxxxx
331 User xxxxxx OK. Password required
Password:
530 Authentication failed, sorry
Login failed.
Quit
This happens for all accounts.
 
Old 11-07-2006, 07:34 PM   #4
furiousV
Member
 
Registered: Aug 2004
Location: Aberdeen, UK
Distribution: Ubuntu, CentOS, FreeBSD
Posts: 64

Rep: Reputation: 15
Red face

Hi guys

I have recently ordered a server from UK2.net for 99p :P

I had them install Debian Stable on it, and was ready earlier on today.

First things I did was disable thigns like apache2, bind, popd etc. Then I did aptitude install pure-ftpd

For some reason it was being run by inetd, but that wasn't really a problem. I connect, type in my own username which I have just created, and my password, only to get the 530 Authentication Failed
I'm 200% sure the password is correct, and have probably tried about a hundred times today.

Things I tried was tinkering with the config folder, chaning 65unix to yes, 70pam to no, and so on and so on.


I even purged pure-ftpd and re-installed it.
Still no luck. Tried running /usr/sbin/pure-ftpd -l unix & but nope.


So, I had another idea: I delete that and compile pure-ftpd from source!

download the latest source from http://download.pureftpd.org/pub/pure-ftpd/releases/
went into the untarred folder:
Code:
./configure --prefix=/opt/pure-ftpd --with-ftpwho

make

make install
Went to /opt/pure-ftpd/sbin and did ./pure-ftpd & and still no luck. Also tried with -l unix but that hasn't helped either

Most of the time while I was checking I had another Putty window open, logged in as non-root and did ftp localhost
I got all the banners and username/password prompts, but always the 530 Authentication Error.

I would really appreciate any ideas.

It will probably turn out to be the most obvious solution and it has been staring me in the face for the past few hours it has been baffling me.

Thanks in advance
 
Old 11-09-2006, 11:34 AM   #5
furiousV
Member
 
Registered: Aug 2004
Location: Aberdeen, UK
Distribution: Ubuntu, CentOS, FreeBSD
Posts: 64

Rep: Reputation: 15
Update - I have resolved my issue

I removed the compiled version of pure-ftpd that I built.

Did as root:
Code:
aptitude install pure-ftpd

cd /etc/pure-ftpd/conf
touch UnixAuthentication
echo yes > UnixAuthentication
You might want to do /etc/init.d/pure-ftpd restart I didn't need to.

Log in as myself via Filezilla and it worked perfect.

I'm sure I have done this before, but it is possible I have made a typo somewhere or tinkered too much.

I hope information helps other people with similar problems.
 
Old 11-09-2006, 06:45 PM   #6
jaxen
LQ Newbie
 
Registered: Nov 2006
Location: UK
Distribution: Debian 3.1 (Stable Sarge)
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by furiousV
Update - I have resolved my issue

I removed the compiled version of pure-ftpd that I built.

Did as root:
Code:
aptitude install pure-ftpd

cd /etc/pure-ftpd/conf
touch UnixAuthentication
echo yes > UnixAuthentication
You might want to do /etc/init.d/pure-ftpd restart I didn't need to.

Log in as myself via Filezilla and it worked perfect.

I'm sure I have done this before, but it is possible I have made a typo somewhere or tinkered too much.

I hope information helps other people with similar problems.
Well its gone from bad to worse. I to restart it and now I cant connect at all.

I then tried to un-install, purge and re-install but it still cant connect- not remotely or even from within the server.

I'm gonna try compiling from source incase there's something up with the debian package.
 
Old 11-09-2006, 07:04 PM   #7
furiousV
Member
 
Registered: Aug 2004
Location: Aberdeen, UK
Distribution: Ubuntu, CentOS, FreeBSD
Posts: 64

Rep: Reputation: 15
Quote:
Originally Posted by jaxen
Well its gone from bad to worse. I to restart it and now I cant connect at all.

I then tried to un-install, purge and re-install but it still cant connect- not remotely or even from within the server.

I'm gonna try compiling from source incase there's something up with the debian package.
Another thing to check in that case: You might be running pure-ftpd to run from inetd.

Edit /etc/default/pure-ftpd-common and change STANDALONE_OR_INETD=whatever-it-is to standalone

In addition to that, go to /etc/inetd.conf and comment out the ftp line - if it exists in there.

Restart pure-ftpd with /etc/init.d/pure-ftpd restart

Or run pure-ftpd with your own settings: /etc/init.d/pure-ftpd stop and then /usr/sbin/pure-ftpd & and see how that works.

Also make sure your firewall isn't getting in the way
 
  


Reply

Tags
account, authentication, error, ftp, pam, pureftpd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
user accounts rmorgan Linux - Server 0 10-31-2006 10:40 AM
LXer: Linux 101: Manage user accounts in a multi-user Linux environment ... LXer Syndicated Linux News 0 06-27-2006 07:03 AM
User Accounts Cool_Hand_Luke Linux - Newbie 6 08-24-2005 08:35 PM
User Accounts petey *BSD 4 09-26-2002 09:28 AM
User Accounts afair Linux - Newbie 3 09-19-2002 12:57 PM


All times are GMT -5. The time now is 10:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration