LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 10-21-2007, 09:49 AM   #1
TheZodiac
LQ Newbie
 
Registered: Oct 2007
Posts: 13

Rep: Reputation: 0
Question ProFTPd trouble


Hi all,

My name's Todd and I'm having some trouble with ProFTPd. Also that the moment, my server won't run Postfix correctly saying "Relay access denied." I'm wondering if ProFTPd's problem is the same as Postfix's. I'll explain what happens.

I start ProFTPd,
Code:
# /etc/init.d/proftpd start
Starting ProFTPD ftp daemon: proftpd.
I try logging in and nothing happens. I run netstat and nothing turns up for ProFTPd. I look at the logs and ProFTPd didn't log anything except for the syslogger in the syslog: "proftpd[10180]: xetaspace.net - socket() failed in connection initialization: Address family not supported by protocol".

I'm somewhat experienced but still inexperienced in all areas of Linux and Debian (which I'm running). So I'm not sure how to fix it. I tried all old ProFTPd configs which worked before all this but now do nothing. I am trying to figure out what's causing this. Does anyone know what I can do? I tried removing and purging ProFTPd and then reinstalling it again but still nothing.

However, when I removed ProFTPd with apt-get, it told me that contents were left in "/var/run/proftpd" and so it wasn't removed which is ironic since I looked and it was removed by apt-get during removal or purging. Could this be part of the problem to ProFTPd not starting?

Any help is appreciated! Thanks very much!

--Todd
 
Old 10-21-2007, 09:58 AM   #2
Chrizzieej
Member
 
Registered: Jan 2007
Location: Netherlands, The
Posts: 50

Rep: Reputation: 15
Hi there,

Probably there's a line in your configuration file (/etc/proftpd/proftpd.conf) which enables the IPV6 protocol. Normally you don't use this so you must modify the configuration file and change UseIPv6 on to UseIPv6 off.

Now you can start ProFTPD using /etc/init.d/proftpd start.

Good luck!
 
Old 10-21-2007, 10:06 AM   #3
TheZodiac
LQ Newbie
 
Registered: Oct 2007
Posts: 13

Original Poster
Rep: Reputation: 0
I tried that but it doesn't seem to work. It's ProFTPd 1.2.16 (I believe) and I tried the UseIPv6 directive but it says,
Code:
Starting ProFTPD ftp daemon:  - Fatal: unknown configuration directive 'UseIPv6' on line 20 of '/etc/proftpd.conf'.
.
Here's my proftpd.conf file:
Code:
#
#	ispCP OMEGA ProFTPd config file
#
#
#
# Includes required DSO modules. This is mandatory in proftpd 1.3
#
#Include /etc/proftpd/modules.conf

ServerName				"xetaspace.net"
ServerType				standalone
DeferWelcome			off

ShowSymlinks			on
MultilineRFC2228		on
DefaultServer			on
ShowSymlinks			on
AllowOverwrite			on
UseReverseDNS			off
IdentLookups			off
AllowStoreRestart		on
AllowForeignAddress		on

LogFormat 				traff "%b %u"

TimeoutNoTransfer		600
TimeoutStalled			600
TimeoutIdle				1200

DisplayLogin			welcome.msg
DisplayFirstChdir		message

#LsDefaultOptions 		"-l"

DenyFilter				\*.*/

DefaultRoot				~

# Uncomment this if you are using NIS or LDAP to retrieve passwords:
#PersistentPasswd		off

# Port 21 is the standard FTP port.

Port					21

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)

MaxInstances			30

# Set the user and group that the server normally runs at.

User					nobody
Group					nogroup

# Normally, we want files to be overwriteable.

<Directory /*>
  # Umask 022 is a good standard umask to prevent new files and dirs
  # (second parm) from being group and world writable.
  Umask				022  022

  AllowOverwrite		on
  HideNoAccess 			on

</Directory>

<Limit ALL>
  IgnoreHidden 			on
</Limit>

<Global>
  RootLogin				off
  TransferLog			/var/log/proftpd/xferlog
  ExtendedLog 			/var/log/proftpd/ftp_traff.log read,write traff
  PathDenyFilter 		"\.quota$"
</Global>

<IfModule mod_delay.c>
	DelayEngine			off
</IfModule>

#
# ISPCP Managment;
#
#SQLBackend				mysql		# enable for proFTPd >= 1.3
SQLAuthTypes 			Crypt
SQLAuthenticate			on
SQLConnectInfo			ispcp@localhost root *********
SQLUserInfo				ftp_users userid passwd uid gid homedir shell
SQLGroupInfo			ftp_group groupname gid members
SQLMinID				2000

#
# ISPCP Quota management;
#

QuotaEngine 			on
QuotaShowQuotas 		on
QuotaDisplayUnits 		Mb

SQLNamedQuery			get-quota-limit SELECT "name, quota_type, per_session, limit_type, bytes_in_avail, bytes_out_avail, bytes_xfer_avail, files_in_avail, files_out_avail, files_xfer_avail FROM quotalimits WHERE name = '%{0}' AND quota_type = '%{1}'"
SQLNamedQuery			get-quota-tally SELECT "name, quota_type, bytes_in_used, bytes_out_used, bytes_xfer_used, files_in_used, files_out_used, files_xfer_used FROM quotatallies WHERE name = '%{0}' AND quota_type = '%{1}'"
SQLNamedQuery			update-quota-tally UPDATE "bytes_in_used = bytes_in_used + %{0}, bytes_out_used = bytes_out_used + %{1}, bytes_xfer_used = bytes_xfer_used + %{2}, files_in_used = files_in_used + %{3}, files_out_used = files_out_used + %{4}, files_xfer_used = files_xfer_used + %{5} WHERE name = '%{6}' AND quota_type = '%{7}'" quotatallies
SQLNamedQuery			insert-quota-tally INSERT "%{0}, %{1}, %{2}, %{3}, %{4}, %{5}, %{6}, %{7}" quotatallies

QuotaLock 				/var/run/proftpd/tally.lock
QuotaLimitTable 		sql:/get-quota-limit
QuotaTallyTable 		sql:/get-quota-tally/update-quota-tally/insert-quota-tally

#
# SSL via TLS
#
#<IfModule mod_tls.c>
#  TLSEngine				off									# on for use of TLS
#  TLSLog					/var/log/proftpd/ftp_ssl.log		# where to log to
#  TLSProtocol				SSLv23								# SSLv23 or TLSv1
#  TLSOptions				NoCertRequest						# either to request the certificate or not
#  TLSRSACertificateFile	/etc/proftpd/ssl.crt				# SSL certfile
#  TLSRSACertificateKeyFile	/etc/proftpd/ssl.key				# SSL keyfile
#  TLSVerifyClient			off									# client verification
#</IfModule>
Not to sound condescending, but I don't think it's a config problem. I even had the default config installed when ProFTPd is installed fresh and it still wouldn't start.

Personally I think it might be a problem with either another program or a port or socket is being blocked.

Last edited by TheZodiac; 10-21-2007 at 11:30 AM.
 
Old 10-21-2007, 10:14 AM   #4
Chrizzieej
Member
 
Registered: Jan 2007
Location: Netherlands, The
Posts: 50

Rep: Reputation: 15
Sorry the IPV6 option is available in a newer version :$

Have you allready tried to uncomment SQLBackend mysql ?
 
Old 10-21-2007, 10:18 AM   #5
TheZodiac
LQ Newbie
 
Registered: Oct 2007
Posts: 13

Original Poster
Rep: Reputation: 0
I tried that but it only gave me an error again saying
Code:
Starting ProFTPD ftp daemon:  - Fatal: unknown configuration directive 'SQLBackend' line 90 of '/etc/proftpd.conf'.
.
The old configs (like the default installed) didn't have any SQL directives/commands and they don't work on ProFTPd now either.
 
Old 10-21-2007, 10:21 AM   #6
Chrizzieej
Member
 
Registered: Jan 2007
Location: Netherlands, The
Posts: 50

Rep: Reputation: 15
Maybe you can upgrade to the new version of ProFTPd. It seems like your total configuration is corrupt. Have you installed some weird stuff on your server which has caused these errors?
 
Old 10-21-2007, 10:29 AM   #7
TheZodiac
LQ Newbie
 
Registered: Oct 2007
Posts: 13

Original Poster
Rep: Reputation: 0
That's just really strange. I only installed ispCP (a VHCS fork) which is a web hosting control panel but it still has compatibility with ProFTPd. And ProFTPd was working about a couple days ago. I would upgrade but I'd need to either build it myself (from ProFTP sources) or upgrade from Sarge (which isn't very likely since my data center controls OS upgrades and such). I'd like to stick to keeping as much preserved as possible.
 
Old 10-21-2007, 10:39 AM   #8
Chrizzieej
Member
 
Registered: Jan 2007
Location: Netherlands, The
Posts: 50

Rep: Reputation: 15
I know what you mean. The advise allways is to use a clean install of you Linux distribution and than install such software as VHCS.
The warn you about allreay configured packages etc. because VHCS etc. installs own versions of things.
 
Old 10-21-2007, 10:45 AM   #9
TheZodiac
LQ Newbie
 
Registered: Oct 2007
Posts: 13

Original Poster
Rep: Reputation: 0
Is there a way to find out if a port is being blocked or if something is affecting ProFTPd's socket?
 
Old 10-21-2007, 11:17 AM   #10
Chrizzieej
Member
 
Registered: Jan 2007
Location: Netherlands, The
Posts: 50

Rep: Reputation: 15
You can use netstat -tap to see which ports are being used. U can also try to find out which firewall rules
are set. I think it's in /etc/iptables.up.rules. Maybe you can install Webmin, it's a handy Administrators tool
for Linux.
 
Old 10-21-2007, 11:42 AM   #11
TheZodiac
LQ Newbie
 
Registered: Oct 2007
Posts: 13

Original Poster
Rep: Reputation: 0
I have Webmin installed and it still won't help.

Now I can't get ProFTPd to start or log anything. So now I'm like a blind man trying to find different colored items. I'm just about ready to re-install everything. It's driving me insane.
 
Old 10-21-2007, 12:13 PM   #12
TheZodiac
LQ Newbie
 
Registered: Oct 2007
Posts: 13

Original Poster
Rep: Reputation: 0
GREAT NEWS!!!! I FIXED IT!!!!!

I was messing around and I tried running ProFTPd as a program and not a daemon and so I set the debug level to 9 and it told me about the invalid socket error, and so I did some Googling and then thought, "What about /etc/hosts?" So I looked at it and remove a few unnecessary lines and low and behold, it worked! I figured it out from another forum post and that's why ProFTPd couldn't start!

Thanks for all your help and advice. This is a really great forum because I have a much quicker response than on other tech support sites.
 
Old 10-22-2007, 04:12 AM   #13
Chrizzieej
Member
 
Registered: Jan 2007
Location: Netherlands, The
Posts: 50

Rep: Reputation: 15
Good to hear it finally works! Your very welcome, glad to be at your service
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
proftpd and iptables trouble kishore2k4 Linux - Server 2 10-14-2007 11:12 PM
Disabling the chroot in proftpd and enabling root logins on ssh/proftpd jon_k Linux - Software 1 06-16-2004 10:27 AM
ProFTPD giving me trouble. freakydude Mandriva 2 08-31-2003 04:47 PM
proftpd --- need help? could someone post a working proftpd.conf i could look at ZooRoPa Linux - Networking 1 04-02-2003 06:56 PM
Trouble with Proftpd and anonymous logins on Mandrake 9 carlmenezes Linux - Software 6 02-25-2003 11:29 PM


All times are GMT -5. The time now is 04:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration