LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 03-16-2007, 11:11 PM   #1
ToothlessRebel
Member
 
Registered: Jun 2004
Location: FL, USA
Distribution: Slackware 9.1
Posts: 190

Rep: Reputation: 30
Question proftpd timing out with passive


I am running proftpd on a gentoo box and can ftp to it fine over the command line. However, must GUI clients now try and switch to passive mode with PASV. Once this occurs, it tries to receive the directory listening for my home directory and it times out. I've been trying to find the problem.

I went to the logs... /var/logs/everything (is there a way to force proftpd to log to its own file?) and first found problems with proftpd trying to set up USEIPv6_V6ONLY: protocol not available. So I set UseIPv6 off in /etc/proftpd/proftpd.conf. Connecting again caused the logs to have entries regarding passive and PassivePorts and MasqueradingPorts, along with timeout entries. So, I added PassivePorts 49152 65534 as noted from an article I found.

I still get:

Quote:
Mar 17 03:21:58 [proftpd] localhost (71.40.151.202[71.40.151.202]) - Passive data transfer failed, possibly due to network issues_
Mar 17 03:21:58 [proftpd] localhost (71.40.151.202[71.40.151.202]) - Check your PassivePorts and MasqueradeAddress settings,_
Mar 17 03:21:58 [proftpd] localhost (71.40.151.202[71.40.151.202]) - and any router, NAT, and firewall rules in the network path._
Mar 17 03:21:58 [proftpd] localhost (71.40.151.202[71.40.151.202]) - FTP no transfer timeout, disconnected_
Mar 17 03:21:58 [proftpd] localhost (71.40.151.202[71.40.151.202]) - FTP session closed._
The machine is on the DMZ of my router, so should have no firewall rules to contend with.

\\EDIT To correct poor formating the best I could.

Last edited by ToothlessRebel; 03-16-2007 at 11:13 PM.
 
Old 03-18-2007, 12:06 PM   #2
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 53
It's either an IP adress problem and/or a port blocked by a firewall.
From a gui, try to enable debug output.
At least from command line, there is debug output:
ftp server
<user,pass>
passive

It will show something like:
227 Entering Passive Mode (127,0,0,1,9,128).
Be sure that the IP adress is accessible from outside: if the server tells the client to connect to your internal adress then it won't work.
Now try ls
If it doesn't work, its a firewall problem.
From the client, try to see if it can connect to 127.0.0.1:2432 (2432=9*256+128, so adapt the IP and port)
You can use netcat for example
nc -vv IP PORT (nc 127.0.0.1 2432 in my case)
 
  


Reply

Tags
proftpd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ProFTPd, Redhat 8.0 and passive mode Slasher Linux - Networking 10 05-09-2008 05:08 PM
proftpd passive state gabsik Linux - Networking 0 09-26-2006 08:25 AM
Proftpd passive connections gabsik Linux - Networking 5 06-18-2006 07:18 AM
how to start timing and print the timing result on portions of java codes ?? alred Programming 2 05-15-2006 11:00 AM
proftpd, passive mode, and a router.... apberzerk Linux - Networking 2 07-11-2004 08:05 PM


All times are GMT -5. The time now is 07:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration