LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Problems with apache/php/mysql/phpmyadmin Using DEBIAN (http://www.linuxquestions.org/questions/linux-server-73/problems-with-apache-php-mysql-phpmyadmin-using-debian-597012/)

antinull 11-04-2007 05:09 AM

Problems with apache/php/mysql/phpmyadmin Using DEBIAN
 
Okay my website is http://antinul.com
Everything on this website worked on my windows me webserver until it bit the dust, now im having link problems

Also Right now im getting an error from phpmyadmin

Forbidden

You don't have permission to access /phpmyadmin on this server.

this is the guide im using to set everything up
http://www.mysql-apache-php.com/

Is there mabey a better guide then this?

antinull 11-04-2007 09:34 PM

i hate to do it but
BUMP

antinull 11-06-2007 06:46 AM

Okay second bump.....
I could really use some help here

flashingcurser 11-06-2007 11:52 AM

What is the home directory for your webpage? I'm guessing it is not in /var/www. Phpmyadmin creates a sym link in /var/www to /usr/share/phpmyadmin If the root of your server isn't there it won't work.

IF that is the problem you can move the symlink to the root of your www server. Check your /etc/apache2 sites-enabled.


Check your settings in /etc/phpmyadmin there may be a setting in there, though I don't remember any.

Also how is your local dns configured? You might try http://local.ip.add.ress/phpmyadmin

Side note: You may also want to set this up the for https.

antinull 11-06-2007 04:02 PM

Quote:

Originally Posted by flashingcurser (Post 2950115)
What is the home directory for your webpage? I'm guessing it is not in /var/www. Phpmyadmin creates a sym link in /var/www to /usr/share/phpmyadmin If the root of your server isn't there it won't work.

Okay there is a phpmyadmin folder with a lock on it in the www dir
Quote:

Originally Posted by flashingcurser (Post 2950115)
IF that is the problem you can move the symlink to the root of your www server. Check your /etc/apache2 sites-enabled.

<Directory /var/lib/phpmyadmin/>
Options -FollowSymLinks
AllowOverride None
Order deny,allow
Allow from 192.168.1.3
</Directory>
could i possibly need to add more ips and how?
Quote:

Originally Posted by flashingcurser (Post 2950115)
Check your settings in /etc/phpmyadmin there may be a setting in there, though I don't remember any.

Also how is your local dns configured? You might try http://local.ip.add.ress/phpmyadmin
[/QUOTE]
i was trying to connect locally and from 192.168 addys
Quote:

Originally Posted by flashingcurser (Post 2950115)
Side note: You may also want to set this up the for https.

https? yeah i dont understand what your saying


All times are GMT -5. The time now is 08:14 PM.