LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 03-16-2012, 10:07 AM   #1
osantos
LQ Newbie
 
Registered: Mar 2011
Posts: 11

Rep: Reputation: 0
Unhappy Problems using robocopy to copy to a samba share.


Hello everyone, I have been fighting with this for a few days now, but can't seem to find the answer.

I have an Ubuntu server 11.10 with samba acting as a PDC.

I can use windows explorer to access the shared folders copy files, edit them, remove them, etc.

I now need to sync information from a windows computer to the samba share and when I runn the robocopy command:

robocopy origin destination /mir

I get an access denied message.

Strange enough If I use windows explorer to copy the same file for which the message is being shown, I can do it without a glitch, but robocopy seems to be trying something that the samba server denies.

Any idea of what it could be?
 
Old 03-16-2012, 05:45 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
What flags or options are you using during the copy?
 
Old 03-20-2012, 05:31 PM   #3
osantos
LQ Newbie
 
Registered: Mar 2011
Posts: 11

Original Poster
Rep: Reputation: 0
O just use the /mir option

I tried coping only data but the error persists
 
Old 03-20-2012, 09:15 PM   #4
jefro
Guru
 
Registered: Mar 2008
Posts: 11,323

Rep: Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386
Map the drive and use it that way.
 
Old 03-21-2012, 02:58 AM   #5
osantos
LQ Newbie
 
Registered: Mar 2011
Posts: 11

Original Poster
Rep: Reputation: 0
I believe I already tried that. But I have tried so manythings that I guess it is worth double checking.

Will keep you posted
Thanks
Oriol
 
Old 03-28-2012, 04:23 PM   #6
osantos
LQ Newbie
 
Registered: Mar 2011
Posts: 11

Original Poster
Rep: Reputation: 0
Maping the drive does not change anything

I tried maping the drive but the problem persists. It is really strange. Although I can not use robocopy or xcopy (i get an access denied error) by using the GUI I can remove and copy the files although I found out some strange behaviour:

- Some directories do not show the contents.
- If I try to copy the file from windows the copy process stalls for ever.

My clients are Windows 7 and the server is Ubuntu 11.10 running samba 3.5.11

I am starting to believe it is a windows 7/Samba incompatibility. I even did the required register changes in the windows clients.

I might have to buy a windows server to replace the ubuntu.
 
Old 03-28-2012, 04:47 PM   #7
brak44
Member
 
Registered: Aug 2010
Location: Brisbane Australia
Distribution: Centos, Fedora
Posts: 81

Rep: Reputation: 23
Whatever you do don't go backwards to windows server.
Windows explorer is unreliable for large data copying.

I recently used robocopy to copy about 130G to a samba share with no problems whatsoever but this was with a Centos 6.2 64 bit server.
robocopy source destination /E /XC /XN /XO /R:3 /W:10

In your circumstance I'd try copying the data to a NTFS formatted USB drive first as an intermediate step.
Ensure that your Ubuntu supports ntfs.
 
Old 03-29-2012, 02:41 AM   #8
osantos
LQ Newbie
 
Registered: Mar 2011
Posts: 11

Original Poster
Rep: Reputation: 0
Unhappy Problem is not just with robocopy

The problem I have is that my problem is not just with robocopy... It is also exhibiting some other strange behaviour. For example, there is one subdirectory in one of my samba shared resources that although it has files in it it does not show its contents when accessing it through samba.

Al toguether the behavious is unreliable. I suspect that Windows 7 and Samba do not work wll toguether for some reason.

I don't know what else to try and I must provide an answer to my customer somehow.

My hope was that if I fixed the issue with robocopy I would probably be fixing the other issues too.

We are running an application that relies on the samba shares for database storage and the fact that it is not working reliable it is causing me problems. In order to operate we are now using one of the windows 7 clients as server for the other PC.

Best regards
Oriol

Last edited by osantos; 03-29-2012 at 02:43 AM.
 
Old 03-29-2012, 08:34 AM   #9
osantos
LQ Newbie
 
Registered: Mar 2011
Posts: 11

Original Poster
Rep: Reputation: 0
Samba with Windows 7 clients

Does anyone have a samba installation with windows 7 clients? What about acting as a PDC?

Best regards
Oriol
 
  


Reply

Tags
access control list, permission denied, samba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't copy/paste files in samba share directory htamayo Linux - Server 3 03-20-2009 01:34 PM
cant create or copy files to samba share Elnegro8 Linux - Server 27 07-16-2008 08:06 AM
[SOLVED] Bash Script to copy files to SAMBA Share bskrakes Linux - Newbie 4 07-03-2008 07:51 AM
cant copy file from samba's share apeacez Linux - General 1 10-11-2004 10:06 AM
Copy Winbloze file to Samba Share -Sharing Violation tornadoburn Linux - Software 1 11-25-2003 12:07 AM


All times are GMT -5. The time now is 01:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration