LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 09-10-2006, 04:15 PM   #1
0001001
LQ Newbie
 
Registered: Nov 2005
Posts: 7

Rep: Reputation: 0
Problem with vsftpd and passive mode


I've got a problem using vsftpd in passive mode on my server, which is behind a router.
Here's what I've done:

- forwarded the ports 8000-8010 to my server
- compiled and installed vsftpd 2.0.5
- my /etc/vsftpd.conf looks like this:
Code:
anonymous_enable=YES
dirmessage_enable=YES
xferlog_enable=YES
listen=YES
pasv_enable=YES
pam_service_name=vsftpd
pasv_max_port=8010
pasv_min_port=8000
pasv_address=80.149.130.xxx
- started vsftpd manually
- connecting to my server using an ftp client. here's the log file:
Code:
[R] Connecting to 84.149.130.xxx PORT=21
[R] Connected to 84.149.130.xxx 
[R] 220 (vsFTPd 2.0.5)
[R] USER anonymous
[R] 331 Please specify the password.
[R] PASS (hidden)
[R] 230 Login successful.
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Features:
[R]  EPRT
[R]  EPSV
[R]  MDTM
[R]  PASV
[R]  REST STREAM
[R]  SIZE
[R]  TVFS
[R] 211 End
[R] CWD /
[R] 250 Directory successfully changed.
[R] PWD
[R] 257 "/"
[R] TYPE A
[R] 200 Switching to ASCII mode.
[R] PASV
[R] 227 Entering Passive Mode (84,149,130,xxx,234,238)
[R] Opening data connection IP: 84.149.130.xxx PORT: 60142
[R] Data Socket Error: Connection timed out
[R] List Error
As you can see, the client tries to open the data connection on port 60142 instead of using a port between 8000-8010.

Can someone please give me a hint how to get vsftpd to use the ports I've specified?
 
Old 09-12-2006, 07:18 AM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,785
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Unfortunately, your vsftpd.conf file looks good. The only thing I can think of right now is this:

Quote:
- started vsftpd manually
Are you running vsftpd in stand-alone mode or is it being run from inetd/xinetd? The reason I'm asking is that I believe there are other setting that need to be changed and if those aren't proper, it could be causing the problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VSFTPD question...active/passive mode lapzlinux Linux - Networking 4 08-06-2011 01:54 AM
Vsftpd + SSL + Passive = Listing problem subspawn Linux - Software 15 08-03-2010 07:19 PM
FTP: active and passive mode problem with some windows client tda71 Linux - Networking 2 06-14-2005 08:31 AM
vsftpd + passive ports range connexion problem ashokleyland Linux - Networking 1 01-03-2005 12:57 PM
ftp connection problem. It hangs on "entering passive mode" lynchmob09 Linux - Newbie 3 10-31-2003 11:09 AM


All times are GMT -5. The time now is 03:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration