LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 11-05-2007, 03:40 AM   #1
bruban
LQ Newbie
 
Registered: Jul 2007
Location: Melbourne, Australia
Distribution: Debian + Ubuntu
Posts: 1

Rep: Reputation: 0
problem with spamd and Exim 4


Hello,

I'm having some problems getting my incoming mail checked for spam.

Any thoughts are appreciated.


In my Exim 4 paniclog I'm finding a number of the following errors:

Quote:
2007-11-05 19:46:16 1Ioxb6-0007EY-Qt spam acl condition: warning - spamd connection to 127.0.0.1, port 783 failed: Connection refused
2007-11-05 19:46:16 1Ioxb6-0007EY-Qt spam acl condition: all spamd servers failed

System:
Debian 4 (Stable)
exim 4.63 (with package exim4-daemon-heavy)
spamassassin 3.1.7-deb
fetchmail 6.3.6
shorewall 3.2.6


Symptoms:

email is being fetched from external mail server via fetchmail and passed to exim.

exim ignores spam check

client downloads spam email


system background:

server is behind another firewall
server acts as gateway to two small lans


In my rules file for shorewall, I have the following definitions for spamd:

Code:
#
#       Accept spam checks
#
SPAMD/ACCEPT    $FW             $FW



Can anyone point me in the right direction with this please?

Bruce
 
Old 11-05-2007, 06:13 PM   #2
bruban
LQ Newbie
 
Registered: Jul 2007
Location: Melbourne, Australia
Distribution: Debian + Ubuntu
Posts: 1

Original Poster
Rep: Reputation: 0
Solved - problem with spamd and Exim4

Sorry for the trouble.

I was able to resolve this myself.

I'd forgotten to enable spamassassin in /etc/default/spamassassin


Bruce
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Etch + exim4 + sa-exim: sa-exim is not loading Thalagyrt Debian 0 04-18-2007 10:12 AM
problem with exim graziano1968 Linux - General 2 10-20-2006 04:12 PM
Exim problem... jademan83 *BSD 0 01-11-2006 11:33 AM
HELP, need to disable Spamd kyletaz Linux - Software 7 11-22-2005 02:45 PM
exim is failed !!! error:package exim is not installed apache Linux - Software 0 06-24-2004 05:55 AM


All times are GMT -5. The time now is 12:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration