LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 08-28-2009, 08:27 AM   #1
rytec
Member
 
Registered: Mar 2009
Location: Belgium
Distribution: Ubuntu server 12.04 LTS / Raspbian Wheezy
Posts: 64

Rep: Reputation: 7
Problem with Bind9


When I reboot my server, it takes a long time until it has started all processes and this is because Bind9 starts as this :
/usr/sbin/named -u bind -t /var/lib/named
it then uses the old and wrong dns numbers

then I kill this process when i can with the program htop.

then all other remaining processes starts very quick. But then i still have no bind active.
then i start by using webmin the service bind9 and it also uses then the correct dns forwarders.
then i see in htop the process is called :

/usr/sbin/named -c /etc/bind/named.conf

this works good but how can i prevent bind starts with the wrong process but it must use this last one and automatically.

I also checked the rc.local file if there is another command but it is not.
I also deleted already the nscd service, i cleaned the dns cache but still no luck.
 
Old 08-28-2009, 03:04 PM   #2
rweaver
Senior Member
 
Registered: Dec 2008
Location: Louisville, OH
Distribution: Debian, CentOS, Slackware, RHEL, Gentoo
Posts: 1,833

Rep: Reputation: 163Reputation: 163
What distribution are you running?
 
Old 08-31-2009, 01:48 AM   #3
rytec
Member
 
Registered: Mar 2009
Location: Belgium
Distribution: Ubuntu server 12.04 LTS / Raspbian Wheezy
Posts: 64

Original Poster
Rep: Reputation: 7
Ubuntu LTS server 8.04
 
Old 08-31-2009, 07:22 AM   #4
vishesh
Member
 
Registered: Feb 2008
Distribution: Fedora,RHEL,Ubuntu
Posts: 658

Rep: Reputation: 66
think bind-chrootenv is installed on your system. just uninstall bind-chroot and go on
thnks
 
Old 09-01-2009, 02:40 AM   #5
rytec
Member
 
Registered: Mar 2009
Location: Belgium
Distribution: Ubuntu server 12.04 LTS / Raspbian Wheezy
Posts: 64

Original Poster
Rep: Reputation: 7
When I run apt-get remove bind-chroot it says it could not find this package.
I run Webmin and I have searched for installed bind packages and here is my search list result:
bind9 9.4.2.dfsg.P2-2ubuntu0.2 A-E Internet Domain Name Server
bind9-host 9.4.2.dfsg.P2-2ubuntu0.2 A-E Version of 'host' bundled with BIND 9.X
libbind9-30 9.4.2.dfsg.P2-2ubuntu0.2 K-O BIND9 Shared Library used by BIND
libdns32 9.4.2-10 K-O DNS Shared Library used by BIND
libdns35 9.4.2.dfsg.P2-2ubuntu0.2 K-O DNS Shared Library used by BIND
libisc32 9.4.2-10ubuntu0.1 K-O ISC Shared Library used by BIND
libisc35 9.4.2.dfsg.P2-2ubuntu0.2 K-O ISC Shared Library used by BIND
libisccc30 9.4.2.dfsg.P2-2ubuntu0.2 K-O Command Channel Library used by BIND
libisccfg30 9.4.2.dfsg.P2-2ubuntu0.2 K-O Config File Handling Library used by BIND
liblwres30 9.4.2.dfsg.P2-2ubuntu0.2 K-O Lightweight Resolver Library used by BIND
libxcb-xlib0 1.1-1ubuntu1 K-O X C Binding, Xlib/XCB interface library
libxcb1 1.1-1ubuntu1 K-O X C Binding
winbind 3.0.28a-1ubuntu4.8 U-Z service to resolve user and group information from Windows NT servers

Last edited by rytec; 09-01-2009 at 02:46 AM.
 
Old 09-01-2009, 03:14 AM   #6
vishesh
Member
 
Registered: Feb 2008
Distribution: Fedora,RHEL,Ubuntu
Posts: 658

Rep: Reputation: 66
check for package dchroot
thnks
 
Old 09-02-2009, 01:07 AM   #7
rytec
Member
 
Registered: Mar 2009
Location: Belgium
Distribution: Ubuntu server 12.04 LTS / Raspbian Wheezy
Posts: 64

Original Poster
Rep: Reputation: 7
Sorry, no package "dchroot" was found on my system.

But I have changed the /etc/default/bind9 file to this :

OPTIONS="-c /etc/bind/named.conf"
RESOLVCONF=yes

and I do not have to manually stop the chrooted bind anymore, now it works with this change.
But maybe it's not good? what is the difference?
 
Old 09-02-2009, 04:26 PM   #8
rweaver
Senior Member
 
Registered: Dec 2008
Location: Louisville, OH
Distribution: Debian, CentOS, Slackware, RHEL, Gentoo
Posts: 1,833

Rep: Reputation: 163Reputation: 163
Quote:
Originally Posted by rytec View Post
Sorry, no package "dchroot" was found on my system.

But I have changed the /etc/default/bind9 file to this :

OPTIONS="-c /etc/bind/named.conf"
RESOLVCONF=yes

and I do not have to manually stop the chrooted bind anymore, now it works with this change.
But maybe it's not good? what is the difference?
Bind has a long sordid history of being extremely exploitable. One thing that helps isolate it from the rest of the system is running it as a non-privileged user chrooted to a specific directory and unable to see the rest of the file system.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuration problem bind9 poiuytrez Linux - Networking 9 06-13-2009 12:22 AM
UBUNTU bind9 problem xokaido Linux - Server 17 07-28-2008 02:31 AM
Problem on starting BIND9 satimis Linux - Server 2 10-23-2007 06:27 AM
emergency bind9 problem Ratclaws Linux - Software 0 09-02-2005 06:13 PM
Bind9 problem WiWa Linux - Networking 3 06-06-2004 05:27 AM


All times are GMT -5. The time now is 10:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration