LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 03-31-2007, 02:32 AM   #1
ganick
LQ Newbie
 
Registered: Jan 2006
Posts: 19

Rep: Reputation: 0
Problem with amavisd-new clamav on Fedora Core 6


Hi!

I installed Fedora Core 6 including amavisd-new 2.4.4 and ClamAV
0.88.7. Everything worked fine, mails sent via postfix were checked by
ClamAV.
Since the ClamAV version is outdated, I updated to a newer version
0.90.1 as follows (using yum and atrpms repo):
<snip>
# yum update clamav
...
Running Transaction
Updating : clamav [1/7]warning: /etc/clamd.conf created as /etc/clamd.conf.rpmnew
Updating : clamav [1/7]warning: /etc/freshclam.conf created as /etc/freshclam.conf.rpmnew
Updating : clamav ###### [1/7]warning: /var/lib/clamav/daily.cvd saved as /var/lib/clamav/daily.cvd.rpmsave
Updating : clamav ######################## [1/7]warning: /var/lib/clamav/main.cvd saved as /var/lib/clamav/main.cvd.rpmsave
Updating : clamav ######################### [1/7]
Cleanup : clamav ######################### [2/7]
warning: /etc/sysconfig/freshclam saved as /etc/sysconfig/freshclam.rpmsave
Removing : clamav-update ######################### [3/7]
Removing : clamav-server-sysv ######################### [4/7]
Removing : clamav-server ######################### [5/7]
Removing : clamav-lib ######################### [6/7]
Removing : clamav-data ######################### [7/7]

Updated: clamav.i386 0:0.90.1-26.fc6.at
Complete!
</snip>
After the above I merged clamd.conf with clamd.conf.rpmnew and
freshclam.conf with freshclam.conf.rpmnew. Now I have only
/etc/clamd.conf and /etc/freshclam.conf

But now I have the problem, that the script clamd.amavisd which starts the
clamd for amavis doesn't run:
<snip>
/etc/init.d/clamd.amavisd: line 7: /usr/share/clamav/clamd-wrapper:
file or directory not found
</snip>
So the clamd doesn't start and mails are not checked:
Does anyone know how to fix the startup script and to reconnect
amavisd and ClamAV?

Last edited by ganick; 03-31-2007 at 02:35 AM.
 
Old 04-02-2007, 09:55 AM   #2
ramram29
Member
 
Registered: Jul 2003
Location: Miami, Florida, USA
Distribution: Debian
Posts: 848
Blog Entries: 1

Rep: Reputation: 47
I would suggest to backup your *.conf files then deinstall clamav* then reinstall and make the changes manually, gradually.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
amavisd with sendmail problem leiw Linux - Newbie 3 01-15-2010 03:57 AM
Problem with amavisd-new combilli Linux - Software 0 11-07-2006 02:50 AM
Problem Installing ClamAV on Fedora Core 5 system. Miketsho Linux - Software 5 10-06-2006 06:22 PM
Problem installing amavisd Koven Linux - Software 0 02-21-2005 02:31 PM
Amavisd-new: Interface to Sendmail milter + ClamAV cyberjames Slackware 0 02-07-2005 02:41 AM


All times are GMT -5. The time now is 08:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration