LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 11-01-2006, 01:21 AM   #1
r_balest
LQ Newbie
 
Registered: Apr 2006
Posts: 14

Rep: Reputation: 0
Problem on DNS server using Bind


hi, guys... please help...
I'm using Mandriva 2006 and currently on the trial to DNS server using bind

here's my configuration:
- /etc/named.conf: zone "e-doc.co" in {
type master;
file "db.e-doc.co";
allow-update {none;};
};

zone "9.168.192.in-addr.arpa" in{
type master;
file "rev.e-doc.co";
allow-update {none;};
};

- db.e-doc.co: @IN NS NS1.e-doc.co
@IN NS NS2.e-doc.co
e-document in A 192.168.9.14

- /etc/resolv.conf: search e-doc.co
nameserver 127.0.0.1

I have an application running on 192.168.9.14 [Windows XP], and my DNS server is running on 192.168.9.158 [Linux Mandriva 2006]. If I tried on 9.158 on the firefox and I enter: http://e-document and it worked. BUT, if I try that on 192.168.9.xxx [other IP address but the same segment], it wont show up...
can somebody please point my mistake? Thanks
 
Old 11-01-2006, 03:12 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,970

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
You have to use your dns IP (192.168.9.158) to the other PCs on 192.168.9.xxx subnet
 
Old 11-01-2006, 03:16 AM   #3
r_balest
LQ Newbie
 
Registered: Apr 2006
Posts: 14

Original Poster
Rep: Reputation: 0
i have entered 192.168.9.158 as the primary DNS Address but still i can't access the http://e-document... did I miss something here?
 
Old 11-01-2006, 03:53 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,970

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
In your linux box you can find the URL http://e-document because you have the "search ..." line in your resolv.conf. For the other boxes you must give the FQDN in your url i.e. http://e-document.e-doc.co, or make the appropriate changes in their /etc/resolv.conf
 
Old 11-01-2006, 04:05 AM   #5
r_balest
LQ Newbie
 
Registered: Apr 2006
Posts: 14

Original Poster
Rep: Reputation: 0
umm.. bathory, but other machines are windows based... only my DNS server is operating on Linux...
so, should I add the http://e-document.e-doc.co on every single windows machines? if so, how do i do it?

Thanks very much for the kind replies...
 
Old 11-01-2006, 04:17 AM   #6
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,970

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Does this URL http://e-document.e-doc.co work on your windows boxes? If it does, but you don't want to give the FQDN in the URL, then go to every windows box and change the dns settings to append your domain name suffix.

Regards
 
Old 11-01-2006, 04:42 AM   #7
r_balest
LQ Newbie
 
Registered: Apr 2006
Posts: 14

Original Poster
Rep: Reputation: 0
no, bathory... the Full Qualified name didn't work.. I entered http://e-document.e-doc.co but it returned error message: "Host name lookup for 'e-document.e-doc.co' failed"

EDIT: bathory i just tried, if I ping e-document.e-doc.co from windows command prompt, it will return a replies...
so, does this simplify what seems to be the problem?

Thanks

Last edited by r_balest; 11-01-2006 at 04:47 AM.
 
Old 11-01-2006, 05:36 AM   #8
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,970

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Check the dns setting of the windows boxes and perhaps the hosts file (WINDOWS\system32\drivers\etc\hosts) for wrong entries.
 
Old 11-01-2006, 11:57 PM   #9
r_balest
LQ Newbie
 
Registered: Apr 2006
Posts: 14

Original Poster
Rep: Reputation: 0
bathory: do i have to check every host files? i have around 200 PC's in my office and i want them all use my DNS server... setting every PC will be a pain...
 
Old 11-02-2006, 03:06 AM   #10
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,970

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Just check 1 or 2 boxes. Then try to setup the correct dns settings to one of them to see if it works.
Are your windows boxes using a proxy?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dns server (bind) with only one ip? ssfrstlstnm Linux - Networking 2 07-06-2006 11:52 AM
BIND 9 DNS server niranjan_mr Linux - Software 2 08-05-2005 05:32 AM
subdomain in the dns server bind c0nsur Linux - Software 4 03-29-2005 05:11 PM
Bind Dns Server nexact Linux - Networking 2 02-21-2004 03:10 PM
help with bind dns server!!!! debloxie Linux - Networking 4 01-22-2004 08:15 AM


All times are GMT -5. The time now is 05:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration