LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 01-03-2013, 10:41 AM   #1
rafiahmadjan
LQ Newbie
 
Registered: Nov 2012
Posts: 9

Rep: Reputation: Disabled
Unhappy Problem installing gcc


Dear all,
I tried to install gcc on my linux server but i got the error as follows
yum install gcc
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

libssl.so.10: cannot open shared object file: No such file or directory

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.6.6 (r266:84292, Sep 12 2011, 14:03:14)
[GCC 4.4.5 20110214 (Red Hat 4.4.5-6)]

If you cannot solve this problem yourself, please go to
the yum faq at:
http://yum.baseurl.org/wiki/Faq

The Openssl package is intalled with following version;
rpm -aq| grep openssl
openssl098e-0.9.8e-17.el6.x86_64


Also
uname -a
Linux WEB-SMS 2.6.32-220.el6.x86_64 #1 SMP Wed Nov 9 08:03:13 EST 2011 x86_64 x86_64 x86_64 GNU/Linux


Kindly help with the same

Regards
rafi
 
Old 01-03-2013, 12:22 PM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 13,481

Rep: Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803
this it what ? ( from the "el6" )
RHEL6.3 ? CentOS 6.3 ? ScientificLinux 6.3 ?

gcc IS IN the base repo for all of them
and yum IS installed by default -- no need to install it
Code:
su -
yum search gcc
and that will give you a very long list to select from

Also VERY IMPORTANT !!!!
yum REQUIRES the version of python that is in the base / update repo !!!
-- it MUST be used --

Now you can install a second version of python ( side by side) with it
but the version in the base / update repo must be installed
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem for installing another gcc in redhat 7.3 mting923 Linux - Newbie 4 10-20-2005 05:27 PM
Problem installing gcc HiOctane21 Linux - Software 5 09-08-2005 07:14 PM
Problem installing GCc rangalo Linux - Software 4 01-31-2005 06:32 AM
Problem with 'cc' while building/installing gcc 3.4.0 linuxalien Programming 1 05-06-2004 04:18 AM
Problem installing GCC with mandrake calimer Linux - Software 3 12-21-2002 11:17 AM


All times are GMT -5. The time now is 02:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration