LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 04-01-2012, 09:02 AM   #1
pendrive
Member
 
Registered: Mar 2011
Posts: 51

Rep: Reputation: 2
Unhappy Problem in making postfix to work out of the localhost


Hi all
I've installed a postfix mail server in my ubuntu server and it's work fine for localhost, I mean when I issue:

Code:
telnet localhost 25
on the server shell, it do great. while when I come to do telnet from a remote client,

Code:
telnet server_ip 25
it connects for a wile and without prompting the postfix output, it falls to disconnect.

even I do the telnet server_ip 25 in the server shell and it fails the same way.

here is my main.cf contents:

Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=no
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = some_domain_name.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = some_domain_name.com, localhost
relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 the_server_ip/24
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all

#
# I added For virtual mailbox and users
#
virtual_mailbox_domains = /etc/postfix/vhosts
virtual_mailbox_base = /home/vmail
virtual_mailbox_maps = hash:/etc/postfix/vmaps
virtual_minimum_uid = 1000
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
inet_protocols = all
as you know some_domain_name.com and the_server_ip are changed for security stuff.

As I get in the internet, people are just taking care of the
Code:
inet_interfaces = all
and
Code:
mynetworks=
for making postfix do on remote case, but I think mine is good. and besides my iptables is not seem to be the cause, I made them pass every thing and after telnet I connects for a while,

and the netstat output shows me:

Code:
0.0.0.0:25
it means postfix is not bound to 127.0.0.1 only

and finaly my postfix version is:

Code:
mail_version = 2.7.0
I don't know what to do more, so for the love of god, any ideas ??!!!!!!????????
 
Old 04-01-2012, 09:09 AM   #2
jaybutts
LQ Newbie
 
Registered: Apr 2012
Location: Detroit
Distribution: Centos, Gentoo, Debian, Ubuntu, FreeBSD
Posts: 5

Rep: Reputation: Disabled
Is it open to world on the firewall? type iptables -L -vn
 
Old 04-01-2012, 11:31 AM   #3
pendrive
Member
 
Registered: Mar 2011
Posts: 51

Original Poster
Rep: Reputation: 2
thanks for the reply jaybutts

As I said, I made iptables pass every thing and besides, telnet connections takes effect (that shows us there is no iptables problem), but it sounds smtp server refuse the connections
 
Old 04-06-2012, 08:16 PM   #4
pendrive
Member
 
Registered: Mar 2011
Posts: 51

Original Poster
Rep: Reputation: 2
few days ago I fixed this, you know, I did mistake in putting my network address in main.cf and I putted the ip address, and the other one was in double putting my hostname in the mydistination entry and in the vmail files. its solved now
 
  


Reply

Tags
localhost, postfix, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Postfix and fetchmail problem: sending mail as localhost instead the right domain allanwiese Linux - Server 1 03-10-2011 07:19 AM
I have a problem making TightVNC work zener Linux - Networking 2 11-10-2006 09:42 AM
Problem Making ATM work dc740 Linux - Networking 0 04-04-2006 11:58 AM
Making Perl/CGI work on "localhost". xode Mandriva 2 10-25-2004 10:23 PM
Postfix: localhost.domain.com iantri Linux - Networking 8 07-27-2004 11:21 AM


All times are GMT -5. The time now is 12:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration