LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   problem in knockd configuration in ubuntu 10.04 (http://www.linuxquestions.org/questions/linux-server-73/problem-in-knockd-configuration-in-ubuntu-10-04-a-948415/)

arun5002 06-04-2012 06:03 AM

problem in knockd configuration in ubuntu 10.04
 
Hi all

Im configuration port knocking configuration in ubuntu server 10.04 DISTRO .i had blocked all the port in my ubuntu server .Im trying to knock the server from client to open the server port number 22.I followed the below link ,But when i try to hit the server from client it does int prompt for password.Can anyone help me in wat wrong in the configuration

Error


root@demo:~# service knockd restart
/etc/default/knockd: 19: logfile: not found
root@demo:~# cat /etc/default/knockd
################################################
#
# knockd's default file, for generic sys config
#
################################################

# control if we start knockd at init or not
# 1 = start
# anything else = don't start
#
# PLEASE EDIT /etc/knockd.conf BEFORE ENABLING
#START_KNOCKD=0

# command line options
KNOCKD_OPTS="-i eth1"


#[options]
logfile = /var/log/knockd.log

[SSH]
sequence = 7000,8000,9000
seq_timeout = 5
start_command = ufw allow from %IP% to any port 22
tcpflags = syn
cmd_timeout = 10
stop_command = ufw delete allow from %IP% to any port 22
root@demo:~#

arun5002 06-30-2012 01:30 AM

Hi
Can anyone help me a good link for configuring ,port knocking in ubuntu 10.04 Lucid

TB0ne 07-01-2012 04:53 PM

Quote:

Originally Posted by arun5002 (Post 4715525)
Hi
Can anyone help me a good link for configuring ,port knocking in ubuntu 10.04 Lucid

Can anyone help me in wat wrong in the configuration

Don't bump your own threads...all you've done is remove it from the zero-reply list, and make it LESS visible. And as we've asked you before, spell out your words.

Did you read what you posted??? Specifically, this line???
Quote:

Originally Posted by arun5002
/etc/default/knockd: 19: logfile: not found

It's telling you that it can't find the log file you specified in the knockd configuration file. So create it...either use vi or type in "touch /path/to/file". Also, Google has MANY how-to's on configuring it, if you tried to look; some are even on the Ubuntu documentation site:
https://help.ubuntu.com/community/PortKnocking


All times are GMT -5. The time now is 03:12 PM.