LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 10-23-2007, 07:51 AM   #1
jjp001
LQ Newbie
 
Registered: Sep 2003
Location: Miami, FL
Distribution: Debian, Ubuntu, Fedora
Posts: 15

Rep: Reputation: 0
Problem Executing cgi Script from Plans Calendar


Hello,

I recently installed Plans web calendaring software (http://www.planscalendar.com/) on a Debian 4.0 server. After following the installation instructions and attempting to run it from a Windows XP machine running IE7, I am prompted to save the cgi script on the PC used to browse.

I double-checked the permissions to the .cgi files and they were set to 755. However, the .pl files' permissions were set to 644. I set the latter group of files to 755, stopped and restarted Apache, and no change in the situation.

I also read further on the documentation (http://www.planscalendar.com/doc/dok...id=doc%3Astart) and it stated the installation of CGI::session was required. I installed it via dselect, configured related packages, rebooted the server, and it STILL prompts to save the cgi scripts!!!!! AARRGH!

Any thoughts?

Last edited by jjp001; 10-23-2007 at 03:12 PM. Reason: added steps taken to further attempt to get system running properly
 
Old 10-24-2007, 02:23 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,773

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
If you installed the scripts in their own directory (i.e. /var/www/plans), make sure that you have the following lines:
Code:
<Directory /var/www/plans>
Options +ExecCGI
AddHandler cgi-script .cgi .pl
</Directory>
 
Old 10-24-2007, 07:37 AM   #3
jjp001
LQ Newbie
 
Registered: Sep 2003
Location: Miami, FL
Distribution: Debian, Ubuntu, Fedora
Posts: 15

Original Poster
Rep: Reputation: 0
Question Clarification on Cited Code Requested

Quote:
Originally Posted by bathory View Post
If you installed the scripts in their own directory (i.e. /var/www/plans), make sure that you have the following lines:
Code:
<Directory /var/www/plans>
Options +ExecCGI
AddHandler cgi-script .cgi .pl
</Directory>

I would assume the code cited above goes in the httpd.conf file in Apache; correct?
 
Old 10-24-2007, 07:51 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,773

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Yes, you should add it in apache's httpd.conf.
 
  


Reply

Tags
apache, cgi, perl, pl


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem executing mv command inside shell script pablogosse Linux - General 7 12-16-2009 12:21 PM
executing perl cgi DanTaylor Programming 4 09-21-2006 06:54 PM
Permission denied executing cgi-script Geminias Linux - Networking 4 07-31-2006 10:02 PM
CGI Scripts not executing Mr_Oz Linux - Enterprise 7 04-18-2006 03:21 PM
Executing from cgi theonebeyond Programming 4 10-04-2004 11:30 PM


All times are GMT -5. The time now is 02:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration