LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 09-28-2009, 05:33 AM   #1
midnightmotion
LQ Newbie
 
Registered: Sep 2009
Posts: 2

Rep: Reputation: 0
Question Problem configuring SVN to work over HTTP


I'm setting up SVN on a CentOS release 5.2 server and I've got it running but can't connect to the repository over http yet.

I setup webdav in /etc/httpd/conf/extra/httpd-dav.conf like this:

Alias /svnrepos "/svn/repository"
<Directory "/svn/repository">
Dav On
Options +Indexes
IndexOptions FancyIndexing
AddDefaultCharset UTF-8
AuthType Basic
AuthName "WebDAV Server"
AuthUserFile "/etc/httpd/webdav.users.pwd"
Require valid-user
Order allow,deny
Allow from all
</Directory>

I imported some files and if I list the files using "svn list file:///svn/repository/" I can see the imported files so this all seems to work as it should.

The problem: If I use "svn list http://<servername>/svnrepos/" (and enter the username and password) I get the following error:

svn: Repository moved permanently to 'http://<servername>/svnrepos/'; please relocate

If I would use "svn list http://<servername>/svnrepos/<projectname>" it gives the error:

svn: The OPTIONS response did not include the requested activity-collection-set; this often means that the URL is not WebDAV-enabled


Does this mean there's a redirect on the server somewhere or is this a mistake I made in the WebDav config?
 
Old 09-28-2009, 10:42 PM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
I think the option should be "DAV svn" and you need an SVNPath or a SVNParentPath. Here's my configuration:
Code:
<Location /svn>
    DAV svn
    SVNParentPath /svn
    <LimitExcept GET PROPFIND OPTIONS REPORT>
        AuthType Basic
        AuthName "SVN"
        AuthUserFile /svn/svn.passwd
        Require valid-user
    </LimitExcept>
</Location>
 
Old 09-30-2009, 12:38 PM   #3
midnightmotion
LQ Newbie
 
Registered: Sep 2009
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Matir View Post
I think the option should be "DAV svn" and you need an SVNPath or a SVNParentPath. Here's my configuration:
Code:
<Location /svn>
    DAV svn
    SVNParentPath /svn
    <LimitExcept GET PROPFIND OPTIONS REPORT>
        AuthType Basic
        AuthName "SVN"
        AuthUserFile /svn/svn.passwd
        Require valid-user
    </LimitExcept>
</Location>
Thanks for your answer, too bad the problem seems to be more complicated...

I found out the problem is related to the DirectAdmin installation on the machine: Appearently DirectAdmin is compiled with an older version of Apache without the mod_dav_svn module and now I can't just install the module because of this. Solution should be to recompile the installation but since it needs to be done on a production server I'll hire someone with more knowledge about this kind of stuff..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache: http://localhost (work) http://ipaddress (not working) sarmad Linux - Newbie 7 02-05-2013 08:47 AM
Getting tovid to work with slides (using svn) baxterman Linux - Software 1 07-01-2009 12:30 PM
Configuring Apache in Linux for SVN. lakshmi4linux Linux - Newbie 1 03-30-2009 04:44 AM
svn commit hangs (http server) xowl Linux - Server 1 04-24-2007 04:56 PM
configuring kmail using http and hotmail Randy C Linux - Newbie 6 09-30-2004 10:51 AM


All times are GMT -5. The time now is 02:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration