LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Problem configuring SVN to work over HTTP (http://www.linuxquestions.org/questions/linux-server-73/problem-configuring-svn-to-work-over-http-758192/)

midnightmotion 09-28-2009 04:33 AM

Problem configuring SVN to work over HTTP
 
I'm setting up SVN on a CentOS release 5.2 server and I've got it running but can't connect to the repository over http yet.

I setup webdav in /etc/httpd/conf/extra/httpd-dav.conf like this:

Alias /svnrepos "/svn/repository"
<Directory "/svn/repository">
Dav On
Options +Indexes
IndexOptions FancyIndexing
AddDefaultCharset UTF-8
AuthType Basic
AuthName "WebDAV Server"
AuthUserFile "/etc/httpd/webdav.users.pwd"
Require valid-user
Order allow,deny
Allow from all
</Directory>

I imported some files and if I list the files using "svn list file:///svn/repository/" I can see the imported files so this all seems to work as it should.

The problem: If I use "svn list http://<servername>/svnrepos/" (and enter the username and password) I get the following error:

svn: Repository moved permanently to 'http://<servername>/svnrepos/'; please relocate

If I would use "svn list http://<servername>/svnrepos/<projectname>" it gives the error:

svn: The OPTIONS response did not include the requested activity-collection-set; this often means that the URL is not WebDAV-enabled


Does this mean there's a redirect on the server somewhere or is this a mistake I made in the WebDav config?

Matir 09-28-2009 09:42 PM

I think the option should be "DAV svn" and you need an SVNPath or a SVNParentPath. Here's my configuration:
Code:

<Location /svn>
    DAV svn
    SVNParentPath /svn
    <LimitExcept GET PROPFIND OPTIONS REPORT>
        AuthType Basic
        AuthName "SVN"
        AuthUserFile /svn/svn.passwd
        Require valid-user
    </LimitExcept>
</Location>


midnightmotion 09-30-2009 11:38 AM

Quote:

Originally Posted by Matir (Post 3700072)
I think the option should be "DAV svn" and you need an SVNPath or a SVNParentPath. Here's my configuration:
Code:

<Location /svn>
    DAV svn
    SVNParentPath /svn
    <LimitExcept GET PROPFIND OPTIONS REPORT>
        AuthType Basic
        AuthName "SVN"
        AuthUserFile /svn/svn.passwd
        Require valid-user
    </LimitExcept>
</Location>


Thanks for your answer, too bad the problem seems to be more complicated...

I found out the problem is related to the DirectAdmin installation on the machine: Appearently DirectAdmin is compiled with an older version of Apache without the mod_dav_svn module and now I can't just install the module because of this. Solution should be to recompile the installation but since it needs to be done on a production server I'll hire someone with more knowledge about this kind of stuff..


All times are GMT -5. The time now is 08:17 AM.