LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   postfix unable to send mail. log posted (http://www.linuxquestions.org/questions/linux-server-73/postfix-unable-to-send-mail-log-posted-537842/)

WOP1337 03-15-2007 05:15 PM

postfix unable to send mail. log posted
 
Im trying to install postfix but still unable to successfully send mail as i am getting error messages that i believe i fixed but i keep getting them. When i try to send an email, i use pine. the tail of the log file /var/log/mailog is:


Mar 15 14:11:19 yebat-box postfix/postfix-script: refreshing the Postfix mail system
Mar 15 14:11:19 yebat-box postfix/master[1542]: reload configuration /etc/postfix
Mar 15 14:11:19 yebat-box postfix/qmgr[1860]: 318652150B: from=<root@yebat-box.domain.com>, size=568, nrcpt=1 (queue active)
Mar 15 14:11:19 yebat-box postfix/smtp[1862]: 318652150B: to=<wop1337@gmail.com>, relay=none, delay=1001, delays=1001/0.02/0/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=yebat-box.domain.com type=MX: Host not found, try again)


Here is also my main.cf without all the comments:

queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
l_owner = postfix
mydomain = domain.com
myorigin = domain.com
inet_interfaces = $myhostname
mydestination = $myhostname, localhost.wop1337.com, localhost
unknown_local_recipient_reject_code = 550
mynetworks_style = host
relay_domains = $mydestination
relayhost = yebat-box.domain.com:25
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
home_mailbox = Maildir/
mail_spool_directory = /var/spool/mail
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail
newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin/mailq
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/local/man
sample_directory = /etc/postfix
readme_directory = no
myhostname = yebat-box.domain.com



Thanks for any help

cgjones 03-15-2007 10:39 PM

Try changing
Code:

relayhost = yebat-box.domain.com:25
to
Code:

relayhost =


All times are GMT -5. The time now is 04:54 AM.