LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 10-26-2007, 01:06 PM   #1
lasantha
Member
 
Registered: Oct 2005
Location: Sri Lanka
Distribution: Red Hat, Cent OS
Posts: 38

Rep: Reputation: 16
Smile Postfix SMTP Authentication


I have compiled postfix with cyrus-sasl enable and I have followed the http://www.postfix.org/SASL_README.html as it is to my centos. But my outgoing mail is not authenticated. Either I enable or disable the “my server requires authentication” option in outlook express my mail leave from the out look express, goes to the Postfix server and send to the correct mail box.

If I enable the option mail log displays

Oct 26 16:27:09 lasantha postfix/smtpd[3913]: connect from unknown[10.64.78.2]
Oct 26 16:27:10 lasantha postfix/smtpd[3913]: 00805212F0: client=unknown[10.64.78.2], sasl_method=LOGIN, sasl_username=user2
Oct 26 16:27:10 lasantha postfix/cleanup[3897]: 00805212F0: message-id=<20071026105710.00805212F0@mail.laknet.lk>
Oct 26 16:27:10 lasantha postfix/qmgr[3853]: 00805212F0: from=<user2@laknet.lk>, size=585, nrcpt=1 (queue active)
Oct 26 16:27:10 lasantha postfix/local[3899]: 00805212F0: to=<user1@laknet.lk>, relay=local, delay=0.12, delays=0.1/0.01/0/0.01, dsn=2.0.0, status=sent (delivered to mailbox)
Oct 26 16:27:10 lasantha postfix/qmgr[3853]: 00805212F0: removed
Oct 26 16:27:10 lasantha postfix/smtpd[3913]: disconnect from unknown[10.64.78.2]

If I disable that mail log shows

Oct 26 16:48:53 lasantha postfix/smtpd[6556]: connect from unknown[10.64.78.2]
Oct 26 16:48:53 lasantha postfix/smtpd[6556]: 90FE5212F0: client=unknown[10.64.78.2]
Oct 26 16:48:53 lasantha postfix/cleanup[6559]: 90FE5212F0: message-id=<000801c817f5$e8d2e1e0$cb6b2b7c@abc>
Oct 26 16:48:53 lasantha postfix/smtpd[6556]: disconnect from unknown[10.64.78.2]
Oct 26 16:48:53 lasantha postfix/qmgr[3853]: 90FE5212F0: from=<user1@laknet.lk>, size=1310, nrcpt=1 (queue active)
Oct 26 16:48:53 lasantha postfix/local[6560]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Oct 26 16:48:53 lasantha postfix/local[6560]: 90FE5212F0: to=<user2@laknet.lk>, relay=local, delay=0.19, delays=0.15/0.03/0/0.01, dsn=2.0.0, status=sent (delivered to mailbox)
Oct 26 16:48:53 lasantha postfix/qmgr[3853]: 90FE5212F0: removed

I need each and every instance to authenticate a mail comes from email client to smtp server (in short and sweet, I only need to set up a postfix server to accept mail from out look client to the server if the “my server requires authenticating enabled”)

How can I do this? What are the settings? I would appreciate if some one can help me?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Little help about SMTP authentication bukich Linux - Software 1 11-04-2006 11:11 AM
postfix installation on suse with smtp authentication murattas Linux - Software 0 05-03-2005 11:16 AM
Postfix smtp authentication help dt23 Mandriva 1 09-28-2004 08:32 PM
smtp authentication ashfaq Linux - Software 1 02-25-2004 01:59 AM
SMTP Authentication msmith7735 Linux - Software 1 11-26-2002 05:24 PM


All times are GMT -5. The time now is 10:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration