LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 04-15-2008, 07:23 PM   #1
polemon
Member
 
Registered: Jun 2005
Distribution: Fedora 18, Ubuntu 11.10, Ubuntu Server 11.10, DamnSmallLinux 3.4.4, FreeDOS 1.1, OpenBSD 5.0
Posts: 194

Rep: Reputation: 31
Postfix: not relaying mails anywhere but own network


Hi!

I've set up postfix, to manage mails.

I can receive mails from everywhere. Now I'd like to use this server as server from which I can send my Mails to anywhere.

I plan to instate authentication once this works, so it can't be abused as SPAM realy.

This is my config so far:

Code:
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

#myhostname = v32210.1blu.de
myhostname = polemon.org
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = polemon.org, v32210.1blu.de, localhost.1blu.de, localhost
relayhost = 
mynetworks = 127.0.0.1/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
home_mailbox = Maildir/
relay_transport = relay
relay_domains = 0.0.0.0/32

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
I've set 'relay_transport' to 'relay' and 'relay_domains' to '0.0.0.0', but the server still refuses to relay my mails anywhere, when I try to send one from my PC, which due to his dynamic IP, is an "untrusted" computer.

Could someone please tell me how to make Postfix relay my mail everywhere?

Regards,
--polemon
 
Old 04-15-2008, 07:45 PM   #2
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Can you please post the output of

postconf -n

and also, try sending an email and pot the relevant part of your log (in FC% I think it's /var/log/maillog)

Don't post the whole thing though...
 
Old 04-16-2008, 08:51 AM   #3
polemon
Member
 
Registered: Jun 2005
Distribution: Fedora 18, Ubuntu 11.10, Ubuntu Server 11.10, DamnSmallLinux 3.4.4, FreeDOS 1.1, OpenBSD 5.0
Posts: 194

Original Poster
Rep: Reputation: 31
This is what postconf -n says:
Code:
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
home_mailbox = Maildir/
inet_interfaces = all
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
mydestination = polemon.org, v32210.1blu.de, localhost.1blu.de, localhost
myhostname = polemon.org
mynetworks = 127.0.0.1/8
myorigin = /etc/mailname
recipient_delimiter = +
relay_domains = 0.0.0.0/32
relay_transport = relay
relayhost = 
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
this is in mail.log:
Code:
Apr 16 15:46:02 v32210 postfix/smtpd[31993]: connect from e179234032.adsl.alicedsl.de[85.179.234.32]
Apr 16 15:46:35 v32210 postfix/smtpd[31993]: NOQUEUE: reject: RCPT from e179234032.adsl.alicedsl.de[85.179.234.32]: 554 <admin@justbase.fm>: Relay access denied; from=<bereziak@polemon.org> to=<admin@justbase.fm> proto=SMTP helo=<polemon.org>
Apr 16 15:47:50 v32210 postfix/smtpd[31993]: disconnect from e179234032.adsl.alicedsl.de[85.179.234.32]
 
Old 04-16-2008, 11:40 PM   #4
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
85.179.234.32 isn't on you network (as in mynetworks) so of course it won't relay.

If this is from outside of your network (which I assume it is), you should require the user to authenticate (look at sasl authentication - howtos on www.postfix.or.

http://www.postfix.org/docs.html

I internal, fix your mynetworks setting.

Do a quick check from the server to ensure you can send mails to external recipients (just use the mail command like "mail -s something me@hotmail.com)

Edit - take a bit of care here - don't create an open relay

Last edited by billymayday; 04-16-2008 at 11:43 PM.
 
  


Reply

Tags
mta, postfix, relay


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix relaying problem tsyuoi Linux - Server 3 10-18-2007 01:15 PM
Problem in relaying outbound mails for specific smtp gurl4sh25 Linux - Server 3 08-31-2006 11:39 PM
Postfix Relaying trueguy2001_in Linux - Security 1 02-22-2006 02:03 PM
Postfix and relaying, help! Sizam Linux - Software 1 04-11-2005 04:37 PM
Relaying with Linux Postfix 1.1.7 - please help BaDaBooM Linux - General 2 04-02-2003 08:24 PM


All times are GMT -5. The time now is 07:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration