LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 05-29-2008, 06:54 AM   #1
boxenberg
LQ Newbie
 
Registered: Sep 2006
Posts: 19

Rep: Reputation: 0
Postfix issue - no local interface found for (invalid) ip


Greetings,
Apparently my Postfix which has been running fine for the last three months suddenly and mysteriously broke.
In my mail log I am receiving the following error messages:
<snip>
May 29 03:03:48 bocacentral postfix/master[22144]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
May 29 03:03:51 bocacentral postfix[28179]: fatal: parameter inet_interfaces: no local interface found for 69.50.160.213
May 29 03:04:22 bocacentral postfix[3657]: fatal: parameter inet_interfaces: no local interface found for 69.50.160.213
May 29 03:26:27 bocacentral postfix[32672]: fatal: parameter inet_interfaces: no local interface found for 69.50.160.213
May 29 03:31:01 bocacentral postfix[6140]: fatal: parameter inet_interfaces: no local interface found for 69.50.160.213
</snip>
I looked everywhere, particularly main.cf and master.cf, hosts, etc. and the config files appear to have my correct and valid IP addressing.
It seems Postfix will not even start because if I go to /etc/init.d and try to manually restart Postfix it throws a similar error.
I am also running Apache on this box and that seems to be fine...I can access any web pages via URL without having to specify IP.
Where is Posftix getting this bogus IP address??? How can I fix it? And the big question, would someone please enlighten me as to how this could have happened to begin with.
The only recent "changes" I am aware of are an increase in disk space and memory to my VPS, but to the best of my knowledge that is all.
Thanks!
 
Old 05-29-2008, 08:11 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966
can you show us your config and the ifconfig output on your system? seems you have a line that reads "inet_interfaces = 69.x.y.z" when that IP is not on your actual server.
 
Old 05-29-2008, 09:06 AM   #3
boxenberg
LQ Newbie
 
Registered: Sep 2006
Posts: 19

Original Poster
Rep: Reputation: 0
postfix problem - interface not found

Hi Chris,
Thanks for your reply.
Here are the results of my ifconfig:
<snip>
bocacentral:~# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:3380 errors:0 dropped:0 overruns:0 frame:0
TX packets:3380 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1013889 (990.1 KiB) TX bytes:1013889 (990.1 KiB)

venet0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:127.0.0.1 P-t-P:127.0.0.1 Bcast:0.0.0.0 Mask:255.255.255.255
UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1
RX packets:791 errors:0 dropped:0 overruns:0 frame:0
TX packets:695 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:68899 (67.2 KiB) TX bytes:71504 (69.8 KiB)

venet0:0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:206.123.89.201 P-t-P:206.123.89.201 Bcast:0.0.0.0 Mask:255.255.255.255
UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:
</snip>

Here are the contents of my main.cf:
<snip>
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = mail.bocacentral.com
mydomain = bocacentral.com
alias_maps = hash:/etc/aliases, hash:/etc/mail/aliases, hash:/var/lib/mailman/data/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination =$myhostname, $mydomain
relayhost =
relay_domains = $mydestination, bocacentral.com
mynetworks = 127.0.0.1, 206.123.89.201
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = ALL
alltransport_maps = hash:/etc/postfix/transport
mailman_destination_recipient_limit = 1
</snip>

Thanks,
B
 
Old 12-04-2010, 04:26 AM   #4
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
I just had this problem. I have about three different websites running on my server and just removed one but forgot to update the postfix main.cf file. Somehow postfix detected that the domain I removed was no longer attached to my nameservers and caused the problem. After removing the domain it worked.
 
Old 12-04-2010, 05:03 AM   #5
Noway2
Senior Member
 
Registered: Jul 2007
Distribution: Ubuntu 10.10, Slackware 64-current
Posts: 2,124

Rep: Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776
I saw an interesting piece of information here. Perhaps there is some old configuration information that it is still getting.

Quote:
postfix runs in a *kind of* chrooted environment
Take a look at /var/spool/postfix there are some insteresting things there like: /var/spool/postfix/etc/resolv.conf

this why postfix was using an old IP address. postfix had not been updated and therefore was using your old network settings.
 
Old 12-04-2010, 05:07 AM   #6
Noway2
Senior Member
 
Registered: Jul 2007
Distribution: Ubuntu 10.10, Slackware 64-current
Posts: 2,124

Rep: Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776
Also take a look here. BTW, I googled for "fatal: parameter inet_interfaces: no local interface found for" with quotes and found that this seems to be fairly common symptom, but many causes. It seems that there may be some IPV6 issues. I noticed that your interfaces looks unusual, with the loopback interface and a virtual loopback interface, but no physical ones. I suspect this is because of your VPS.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot get interface flags: Invalid argument nasim751 Linux - Software 1 04-21-2008 07:20 PM
Cannot get interface flags: Invalid argument nasim751 Linux - Software 1 04-21-2008 07:18 PM
Cannot get interface flags: Invalid argument nasim751 Programming 1 04-21-2008 12:22 PM
Postfix: Invalid domain nukoso Linux - Server 2 02-11-2008 12:57 PM
Postfix host name not found + samba issue emulite Linux - Server 1 03-30-2007 05:07 PM


All times are GMT -5. The time now is 11:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration