LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 10-11-2009, 08:20 PM   #1
djuhl30
Member
 
Registered: Dec 2005
Location: IRAQ (BACK @ FT HOOD NOW)
Distribution: GENTOO now
Posts: 98

Rep: Reputation: 15
Postfix - I can send mail from my computer; but others can't send to me...


I am attempting to set up a mail server, because I lack anything better to do and I run linux...

The output of postconf -n is here...
http://dpaste.com/105933/

I have a domain name from dyndns.org.

I need to relay may mail to another mailhop because yahoo won't accept someone on a PBL list. Something I saw here http://forums.fedoraforum.org/showthread.php?t=225797

This is what I think I got:

My smtp server using cyrus-sasl with pam authentication.. It works when I telnet in it...

Mail does get sent to outbound.mailhop.org:2525 and it does get authenticated there...

I can basically send a email to another person from this machine..

But what doesn't happen people sending mail to me from their email client...

I've tested this by actually logging into my yahoo account and trying to send mail to my home email server...

I can only act like I know what I am doing... So if I seem stupid I probably am... Can't learn unless you don't try..

Any help would be appreciated...

David...
 
Old 10-11-2009, 09:04 PM   #2
Steel_J
Member
 
Registered: Oct 2004
Location: Montreal, Canada
Distribution: Kubuntu 10.04, Mint 8 and Puppy 4.3.1
Posts: 355
Blog Entries: 1

Rep: Reputation: 31
I would start with the obvious; Firewall issue.

Either your router or you server's ip-table rules is blocking a necessary inbound port or protocol.

I would log in to my router and have a look at the logs after trying to send an email. Then also look into your server /var/log messages around the pertinent times and dates of your test email.
 
Old 10-11-2009, 10:32 PM   #3
djuhl30
Member
 
Registered: Dec 2005
Location: IRAQ (BACK @ FT HOOD NOW)
Distribution: GENTOO now
Posts: 98

Original Poster
Rep: Reputation: 15
Hmm.. as far as I can tell I have port 25000 forwarded via the router..

10/11/2009 18:46:10 **SYN Flood to Host** 85.190.0.3, 49839->> 24.242.54.169, 8015 (from WAN Inbound)
10/11/2009 15:46:05 **Smurf** 216.146.33.255, 56664->> 24.242.54.169, 25 (from WAN Inbound)
10/11/2009 15:45:59 **Smurf** 216.146.33.255, 56664->> 24.242.54.169, 25 (from WAN Inbound)
10/11/2009 15:45:55 **Smurf** 216.146.33.255, 56664->> 24.242.54.169, 25 (from WAN Inbound)
10/11/2009 15:45:52 **Smurf** 216.146.33.255, 56664->> 24.242.54.169, 25 (from WAN Inbound)
10/11/2009 15:45:49 **Smurf** 216.146.33.255, 56664->> 24.242.54.169, 25 (from WAN Inbound)
10/11/2009 15:45:46 **Smurf** 216.146.33.255, 56664->> 24.242.54.169, 25 (from WAN Inbound)
10/11/2009 15:45:43 **Smurf** 216.146.33.255, 56664->> 24.242.54.169, 25 (from WAN Inbound)
10/11/2009 09:33:01 **UDP Flood to Host** 192.168.2.100, 13280->> 216.146.35.35, 53 (from WAN Outbound)
10/11/2009 09:27:01 **UDP Flood to Host** 192.168.2.100, 24985->> 216.146.35.35, 53 (from WAN Outbound)

System Log
10/11/2009 21:18:45 192.168.2.100 login success
10/11/2009 21:00:43 NTP Date/Time updated.
10/11/2009 15:04:31 192.168.2.100 logout
10/11/2009 15:01:07 192.168.2.100 login success
10/11/2009 15:00:29 192.168.2.100 logout
10/11/2009 15:00:08 DHCP Client: [WAN]Receive Ack from 10.88.4.1,Lease time=86400
10/11/2009 15:00:08 DHCP Client: [WAN]Domain name = hot.rr.com
10/11/2009 15:00:08 DHCP Client: [WAN]Send Request, Request IP=24.242.54.169
10/11/2009 15:00:08 DHCP Client: [WAN]Receive Offer from 10.88.4.1
10/11/2009 15:00:08 DHCP Client: [WAN]Domain name = hot.rr.com
10/11/2009 15:00:08 DHCP Client: [WAN]Send Discover
10/11/2009 14:59:33 192.168.2.100 login success
10/11/2009 11:22:32 DHCP Client: [WAN]Receive Ack from 10.88.4.1,Lease time=86400
10/11/2009 11:22:32 DHCP Client: [WAN]Domain name = hot.rr.com
10/11/2009 11:22:32 DHCP Client: [WAN]Send Request, Request IP=24.242.54.169
10/11/2009 10:03:41 NTP Date/Time updated.
10/11/2009 04:03:40 NTP Date/Time updated.
10/11/2009 00:46:10 DHCP Client: [WAN]Receive Ack from 10.88.4.1,Lease time=76333
10/11/2009 00:46:10 DHCP Client: [WAN]Domain name = hot.rr.com
10/11/2009 00:46:10 DHCP Client: [WAN]Send Request, Request IP=24.242.54.169

it is now 21:29, and I don't know if all this other information is pertinent to my problem..

And I couldn't tell if postfix is getting mail... Because I can't comprend the logs..

Oct 11 21:30:04 lianli postfix/pickup[31030]: 3F43D380A85: uid=1000 from=<david16>
Oct 11 21:30:04 lianli postfix/cleanup[16118]: 3F43D380A85: message-id=<20091012023004.3F43D380A85@davidjuhl>
Oct 11 21:30:04 lianli postfix/qmgr[8160]: 3F43D380A85: from=<david16@davidjuhl.dyndns.org>, size=3037, nrcpt=1 (queue active)
Oct 11 21:30:04 lianli spamd[8118]: spamd: connection from localhost [127.0.0.1] at port 38512
Oct 11 21:30:04 lianli spamd[8118]: spamd: setuid to david16 succeeded
Oct 11 21:30:04 lianli spamd[8118]: spamd: processing message <20091012023004.3F43D380A85@davidjuhl> for david16:1000
Oct 11 21:30:04 lianli spamd[8118]: spamd: clean message (-0.0/5.0) for david16:1000 in 0.4 seconds, 3137 bytes.
Oct 11 21:30:04 lianli spamd[8118]: spamd: result: . 0 - NO_RELAYS scantime=0.4,size=3137,user=david16,uid=1000,required_score=5.0,rhost=localhost,raddr=127.0.0.1,rpor t=38512,mid=<20091012023004.3F43D380A85@davidjuhl>,autolearn=ham
Oct 11 21:30:04 lianli postfix/local[16120]: 3F43D380A85: to=<david16@localhost.dyndns.org>, orig_to=<david16>, relay=local, delay=3.3, delays=2.9/0.01/0/0.45, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail)
Oct 11 21:30:04 lianli postfix/qmgr[8160]: 3F43D380A85: removed
Oct 11 21:30:04 lianli spamd[8044]: prefork: child states: II

is a sample

Dave
 
Old 10-12-2009, 01:59 AM   #4
djuhl30
Member
 
Registered: Dec 2005
Location: IRAQ (BACK @ FT HOOD NOW)
Distribution: GENTOO now
Posts: 98

Original Poster
Rep: Reputation: 15
How do I get this marked solved... Turned out my ISP doesn't block port 25.. I changed postifix back to port 25 and the emails came in.. It doesn't mean my ISP will block port 25 in the future.. Just all works for now..

Dave
 
Old 10-12-2009, 03:26 AM   #5
DrLove73
Senior Member
 
Registered: Sep 2009
Location: Srbobran, Serbia
Distribution: CentOS 5.5 i386 & x86_64
Posts: 1,118
Blog Entries: 1

Rep: Reputation: 129Reputation: 129
Follow my signature :-)
 
Old 10-12-2009, 12:19 PM   #6
djuhl30
Member
 
Registered: Dec 2005
Location: IRAQ (BACK @ FT HOOD NOW)
Distribution: GENTOO now
Posts: 98

Original Poster
Rep: Reputation: 15
Sorry... Letters were small and I've been up all night. Maybe I should sleep... I may have found another solution just to scared to use it at the moment... Anyone know how the /etc/services work in Linux... I saw something here... http://www.dyndns.com/support/kb/mai..._outbound.html

I don't want to do anything until I get a good grasp of what I am doing...

Dave
 
Old 10-12-2009, 12:55 PM   #7
DrLove73
Senior Member
 
Registered: Sep 2009
Location: Srbobran, Serbia
Distribution: CentOS 5.5 i386 & x86_64
Posts: 1,118
Blog Entries: 1

Rep: Reputation: 129Reputation: 129
Question is: What actually are you trying to do? Why do you need Postfix to accept connections on different port if normal application works with normal port (25)? Do you think that other Mailservers all around the world will look at any other port beside 25?

If your ISP decides to block port 25, you will just have to pay for service that will keep that ports open.
 
Old 10-12-2009, 01:57 PM   #8
Steel_J
Member
 
Registered: Oct 2004
Location: Montreal, Canada
Distribution: Kubuntu 10.04, Mint 8 and Puppy 4.3.1
Posts: 355
Blog Entries: 1

Rep: Reputation: 31
The man is totally right. All mail servers will broadcast on the protocol regular port.

It Makes no difference what you do on your end.

Be glad your ISP is allowing the port to be open and enjoy.
 
Old 10-12-2009, 03:34 PM   #9
djuhl30
Member
 
Registered: Dec 2005
Location: IRAQ (BACK @ FT HOOD NOW)
Distribution: GENTOO now
Posts: 98

Original Poster
Rep: Reputation: 15
Yeah basically
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix send mail at once mitchell2345 Linux - Software 2 07-10-2009 09:11 AM
not able to send mail using postfix Robin01 Linux - Software 4 12-28-2007 04:41 PM
Postfix : mail cannot send to send outside ( can send/receive locally) bobbinsupport Linux - Networking 3 12-15-2007 11:40 PM
just send mail using postfix shipon_97 Linux - Networking 1 08-10-2006 07:01 AM
Postfix send mail problem(In RH9, kernal 2.4.20, postfix 2.1.5) minor Linux - General 4 07-11-2005 10:12 PM


All times are GMT -5. The time now is 05:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration