LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 01-04-2011, 08:06 AM   #1
weav
LQ Newbie
 
Registered: Dec 2005
Posts: 14

Rep: Reputation: 0
Postfix: how to explicitly permit "joeblow@mydomain" from certain address ranges


One of our clients uses a mobile client, which "helo"s with a non-resolvable hostname (which contains the correct IPv4 address in the name but does not resolve). I'd like to be able to config PERMIT "joeblow@mydomain" when the helo-name is "*.mobilepool.carrier.net". Can anybody give me a hint how to do this, if it is even possible?

Right now it just rejects based on not resolving the HELO name.

Thanks
 
Old 01-05-2011, 04:16 AM   #2
Noway2
Senior Member
 
Registered: Jul 2007
Distribution: Ubuntu 10.10, Slackware 64-current
Posts: 2,124

Rep: Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776
I would start here. There may be a restrictions setting that you can alter to loosen things up to allow this user. My first thought was what authentication method are you using and would SASL solve your problem. This would avoid the need to restrict authorized senders via host or network. However, I suspect you are getting tripped up on a generalized setting where this particular client doesn't comply with the standards closely enough and gets tagged as invalid.
 
Old 01-05-2011, 06:33 AM   #3
Reuti
Senior Member
 
Registered: Dec 2004
Location: Marburg, Germany
Distribution: openSUSE 11.4
Posts: 1,319

Rep: Reputation: 252Reputation: 252Reputation: 252
Yes, especially check_helo_access can specify a table for smtpd_helo_restrictions to allow access.
 
  


Reply

Tags
postfix


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix-Squirrelmail: Mail sent to user1@mydomain.com delivered to user2@mydomain.com tsouvalasi Linux - Server 4 02-26-2010 08:15 AM
Occasionally-- "connected with self-assigned address," "deactivating device eth0" MaxIBoy Debian 4 10-04-2009 10:50 AM
is there a way to free the resources of a created frame "explicitly" in java ?? alred Programming 4 06-01-2006 03:11 PM
Postfix-Rewrite "From" address in mail on particular condition. dhruvypatel Linux - General 1 04-07-2006 07:39 AM
sendmail from perl always sends as user "nobody"@mydomain johnvoisey Linux - Software 2 05-17-2003 12:24 AM


All times are GMT -5. The time now is 08:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration