LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 03-30-2007, 02:43 PM   #1
ballistic509
Member
 
Registered: Feb 2006
Distribution: CentOS
Posts: 114

Rep: Reputation: 15
Postfix Error


Hello,

When I go to send an email, the server connects and everything comes up like it should, but the message is not sent or received.

Here is the log from a session of sending an email:

Quote:
Mar 30 12:24:21 ns1 postfix/smtpd[3791]: connect from 66-123-123-123.dhcp.ykma.wa.charter.com[66.123.123.123]
Mar 30 12:24:22 ns1 postfix/smtpd[3791]: warning: SASL authentication failure: realm changed: authentication aborted
Mar 30 12:24:22 ns1 postfix/smtpd[3791]: warning: 66-123-123-123.dhcp.ykma.wa.charter.com[66.123.123.123]: SASL DIGEST-MD5 authentication failed: authentication failure
Mar 30 12:24:22 ns1 postfix/smtpd[3791]: B021B31C334: client=66-123-123-123.dhcp.ykma.wa.charter.com[66.123.123.123], sasl_method=LOGIN, sasl_username=user@trickmodz.com
Mar 30 12:24:22 ns1 postfix/cleanup[3794]: B021B31C334: message-id=<000501c77301$08173a50$1845aef0$@com>
Mar 30 12:24:22 ns1 postfix/qmgr[17209]: B021B31C334: from=<user@Trickmodz.com>, size=2588, nrcpt=1 (queue active)
Mar 30 12:24:23 ns1 postfix/smtp[3795]: connect to 127.0.0.1[127.0.0.1]: Connection refused (port 10024)
Mar 30 12:24:23 ns1 postfix/smtp[3795]: B021B31C334: to=<test@hotmail.com>, relay=none, delay=0.69, delays=0.45/0.24/0.01/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)
Mar 30 12:24:25 ns1 postfix/smtpd[3791]: disconnect from 66-123-123-123.dhcp.ykma.wa.charter.com[66.123.123.123]
I see that there is an error stating "status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused" and I do not know what to do to fix it.

Thanks in advance.
 
Old 03-31-2007, 10:46 AM   #2
Biggen
Member
 
Registered: Sep 2004
Location: Panama City Beach FL
Distribution: Slackware 12.2
Posts: 199

Rep: Reputation: 31
Quote:
Originally Posted by ballistic509
Hello,

When I go to send an email, the server connects and everything comes up like it should, but the message is not sent or received.

Here is the log from a session of sending an email:



I see that there is an error stating "status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused" and I do not know what to do to fix it.

Thanks in advance.

Looks like you have SASL (SMTP authorization) enabled. Check your main.cf file for this:
Quote:
smtpd_sasl_auth_enable = yes
If you find it set it to "no". Then restart postfix "postfix reload"

http://www.postfix.org/SASL_README.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix error CaSBoY Debian 9 07-09-2005 10:28 AM
What is postfix and what is this error? jeffreybluml Linux - Newbie 2 06-27-2004 11:53 AM
Postfix error SolidSnake Linux - Software 2 04-08-2004 10:08 AM
can't start postfix ./postfix status error jules_fraser Linux - Software 3 12-06-2003 06:33 PM
postfix error need help ziggie216 Linux - Networking 1 11-12-2003 04:46 PM


All times are GMT -5. The time now is 01:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration