LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 06-19-2008, 08:56 AM   #1
carlosinfl
Senior Member
 
Registered: May 2004
Location: Orlando, FL
Distribution: Arch
Posts: 2,905

Rep: Reputation: 73
Postfix Email Is Stuck In Queue


Everything I try and send out makes it to its destination but I am having problems with what appears to be specific domains sending from my Postfix email server. I am showing the following emails stuck in the queue:

Code:
[root@mail ~]# postqueue -p

92BEF15C03C     1768 Tue Jun 17 13:41:05  tuser7@example.org
(lost connection with mx2.nmci.navy.mil[138.162.0.120] while sending end of data -- message may be sent more than once)
                                         user89@navy.mil

55F9915C043     4560 Tue Jun 17 15:32:45  user205@example.org
(lost connection with mx11.nmci.navy.mil[138.163.129.9] while sending end of data -- message may be sent more than once)
                                         user50@navy.mil

5272D15C044     1702 Tue Jun 17 15:34:17  user205@example.org
(lost connection with mx6.nmci.navy.mil[138.163.129.7] while sending end of data -- message may be sent more than once)
                                         user54@navy.mil

5931715C03A     6872 Tue Jun 17 10:30:19  puser5@example.org
(lost connection with mx11.nmci.navy.mil[138.163.129.9] while sending end of data -- message may be sent more than once)
                                         user21@navy.mil

EDCF415C061     4818 Wed Jun 18 16:54:05  nuser8@example.org
(lost connection with mx1.nmci.navy.mil[138.162.0.118] while sending end of data -- message may be sent more than once)
                                         kuser17@navy.mil

05A0115C036     2501 Mon Jun 16 12:29:12  user4@example.org
(delivery temporarily suspended: lost connection with mx1.nmci.navy.mil[138.162.0.118] while sending end of data -- message may be sent more than once)
                                         user9@navy.mil

38ED815C032     7858 Mon Jun 16 17:22:18  user8@example.com
(delivery temporarily suspended: lost connection with mx1.nmci.navy.mil[138.162.0.118] while sending end of data -- message may be sent more than once)
                                         user4@navy.mil

1B7EC15C063     1174 Wed Jun 18 20:51:31  ptr@example.net
(lost connection with pluto.colsa.com[12.13.161.3] while sending end of data -- message may be sent more than once)
                                         user@colsa.com

C9CD215C040     3640 Tue Jun 17 14:16:33  user@example.org
(lost connection with pluto.colsa.com[12.13.161.3] while sending end of data -- message may be sent more than once)
                                         jvarner@colsa.com

C592315C03B     3640 Tue Jun 17 14:16:33  user@example.com
(delivery temporarily suspended: lost connection with mx1.nmci.navy.mil[138.162.0.118] while sending end of data -- message may be sent more than once)
                                         user1@navy.mil
                                         user2@navy.mil
                                         user3@navy.mil

8B98A15C02E     1415 Tue Jun 17 11:57:33  jmadeline@example.com
(delivery temporarily suspended: lost connection with mx1.nmci.navy.mil[138.162.0.118] while sending end of data -- message may be sent more than once)
                                         example@navy.mil

49D2915C09C     1267 Sun Jun 15 07:00:25  root@example.net
(lost connection with pluto.colsa.com[12.13.161.3] while sending end of data -- message may be sent more than once)
                                         user@colsa.com

BFB5F15C02D     7132 Tue Jun 17 13:35:33  tjervis@ideorlando.org
(delivery temporarily suspended: lost connection with mx1.nmci.navy.mil[138.162.0.118] while sending end of data -- message may be sent more than once)
                                         user@navy.mil

BCDC615C045     6605 Wed Jun 18 09:33:58  tuser6@example.com
(delivery temporarily suspended: lost connection with mx1.nmci.navy.mil[138.162.0.118] while sending end of data -- message may be sent more than once)
                                         user@navy.mil
I don't understand what is causing my server to lose connection with these servers. All the servers that are listed above are able to receive email from Gmail and my AKO email address - just not from example.org (my Postfix server).

Anyone know what I can check or what is causing this?
 
Old 06-19-2008, 02:19 PM   #2
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 59
Perhaps a firewall or router interfering with the SMTP protocol ?

Create a packet trace to one of those destinations, to capture the dialog between your server and the destination.

Ask this question also on the Postfix mailing list - you'll find additional help there.
 
Old 06-19-2008, 10:38 PM   #3
carlosinfl
Senior Member
 
Registered: May 2004
Location: Orlando, FL
Distribution: Arch
Posts: 2,905

Original Poster
Rep: Reputation: 73
Thanks. Yes, Postfix mailing list pointed to my PIX firewall. Wietse Venema actually responded and explained how to trace the packets on Postfix.

Thanks for your reply!
 
Old 06-19-2008, 11:19 PM   #4
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 59
The PIX is what I suspected. Glad you've got it worked out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
remote printer jobs stuck in queue bhert Linux - Server 24 04-12-2008 10:04 AM
SendMail Not Sending, Messages Stuck In Queue As: Deferred: Connection JustinK101 Linux - Software 43 03-30-2007 01:21 AM
Postfix on RH 9 'No Recipient' in queue rangert Linux - Server 3 10-25-2006 12:57 PM
problem with sendmail over ppp - message queue stuck julot Slackware 1 07-17-2006 05:44 AM
Printer queue getting stuck tamim Linux - General 0 10-10-2003 03:28 AM


All times are GMT -5. The time now is 12:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration