-   Linux - Server (
-   -   Postfix catch-all alias problem (using mysql) (

XeroXer 03-03-2009 09:57 AM

Postfix catch-all alias problem (using mysql)
Hi all!

I am having a bit of problems with catch-all alias in postfix.
Today I finally got my postfix/dovecot setup working, using authentication via mysql.
But then I got into a problem, with catch-all alias.

In the database in my alias table I added:

The problem is that the alias is loaded before the regular adresses, so if someone tries to mail to the mail is delivered to
While logging the mysql queries I can see that because it first looks at the aliases in many different ways and because it gets a result with it accepts that.

Does anyone have any idea on how to either modify the query or modify postfix to read the aliases after the adresses?

Raphalon 07-06-2009 03:06 PM

Good morning

Did you arrived to repaired that ?

Because I am facing the same problem

jbova 04-13-2010 01:24 PM

Answer to Postfix virtual alias catch-all problem

I know this thread is quite outdated, but it still appears on search results. I came up with a solution to this problem a few years ago, but was searching to see if anyone came up with a different approach, or if the How-To was updated.

The problem can be duplicated as follows:

* Postfix is set up to use virtual_alias_maps. An example would be as follows in the configuration file:

virtual_alias_maps = mysql:/etc/postfix/
* The file may be configured as follows:

table = virtual
select_field = dest
where_field = alias
additional_conditions = and status = '1' order by alias desc

* The domain is added.

* An account user is created. For example:

* An account is added that will be used as a catch-all. For example:

* An alias is added as a catch-all account. For example, is aliased to

* Now, when mail is sent to, it should be sent to However, it will end up in Thus, the problem arises.

The reason this happens is because Postfix first checks the virtual_alias_maps for an alias. matches as an alias. No other aliases exist. Therefore, the mail is sent to the catch-all account.

There are two possible solutions. The first would be to create an alias for each and every account. For example, your alias table would contain an alias of, with a destination of This is inconvenient if you are using software such as Web-Cyradm to administer your accounts. You cannot tell Web-Cyradm to add this alias for every account without hacking Web-Cyradm.

The better solution would be to update your virtual_alias_maps file, in my case, to search the table holding your virtual e-mail account users. The change can be applied as follows:

Edit the virtual_alias_maps directive in configuration file as follows:

virtual_alias_maps = mysql:/etc/postfix/, mysql:/etc/postfix/
Now, create the file /etc/postfix/ with the following:

table = accountuser
select_field = username
where_field = username
additional_conditions = and status = '1' order by alias desc

Now, when an e-mail is sent to, two matches are found. The returns, which is aliased to The returns, which is aliased to Since is the more specific of the two results, mail is delivered to this address, instead of the catch-all.

Be sure to reload the postfix configuration files before testing.

If you are more curious about the inner workings of this. You can turn on mysql logging and view the queries made both before and after the change. You will see what queries are made.

Please note that you may have to change the mysql-*.cf configuration files to correspond with your table structure. The tables I am using are the default tables used by Web-Cyradm.

If anyone has a better solution, please respond on here. I've used this method for several years without a problem. If you have any questions, please ask.


All times are GMT -5. The time now is 10:04 AM.