LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 04-07-2009, 04:51 AM   #1
black-code
LQ Newbie
 
Registered: Sep 2008
Posts: 5

Rep: Reputation: 0
Please Help me in my load average


Hello AlL,..

I want from experts to help me as my load average is increased and i dont know where is the problem !!

this is my top result :

root@a4s [~]# top
top - 11:30:38 up 40 min, 1 user, load average: 3.06, 2.49, 4.66
Mem: 8168788k total, 2889596k used, 5279192k free, 47792k buffers
Swap: 2031608k total, 0k used, 2031608k free, 1464780k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
15523 mazikaco 16 0 226m 23m 16m S 24.1 0.3 0:08.74 php5
15547 mazikaco 15 0 226m 24m 17m S 17.5 0.3 0:13.74 php5
15516 mazikaco 16 0 226m 27m 20m S 15.9 0.3 0:11.29 php5
15546 mazikaco 16 0 225m 21m 14m S 15.5 0.3 0:09.73 php5
15548 mazikaco 16 0 225m 21m 14m S 13.9 0.3 0:09.40 php5
15522 mazikaco 16 0 226m 23m 16m S 13.5 0.3 0:15.26 php5
2928 mysql 15 0 731m 110m 4112 S 10.6 1.4 3:27.59 mysqld
15517 mazikaco 16 0 225m 26m 19m S 10.2 0.3 0:13.07 php5
15881 mazikaco 15 0 225m 20m 13m S 5.0 0.3 0:01.97 php5
4008 root 15 0 27600 7852 604 S 1.3 0.1 0:43.87 lighttpd
12374 nobody 16 0 71956 6300 2016 S 1.3 0.1 0:01.48 httpd
9565 nobody 15 0 72068 6376 2012 S 1.0 0.1 0:02.74 httpd
12391 nobody 15 0 72008 6324 2016 S 1.0 0.1 0:01.73 httpd
13926 nobody 15 0 71912 6240 2016 S 1.0 0.1 0:00.69 httpd
14368 nobody 15 0 71972 6184 2012 S 1.0 0.1 0:00.82 httpd
15052 nobody 15 0 71912 6204 2008 S 1.0 0.1 0:00.37 httpd
15474 nobody 15 0 71980 6272 2008 S 1.0 0.1 0:00.14 httpd


i have 4 cpus in my server, and i have read before that when the number found in the 15 minutes period exceeds the total number of cpus so there is a load on the server ..

Note that i have daily more than 450,000 visits and this top result was taken with almost 10,000 visits ,,..

AND when the site accepts the 450,000 visits the connection is interrupted and my apache becomes down foer a short time so what is the soln of that load and is the httpd.conf configuration can play a role here , if so please tell me the best?

############
http.conf

timeout 60

and all of these (MinSpareServers,MaxSpareServers,StartServers,MaxClients,MaxRequestsPerChild,KeepAlive,KeepAliveTime out,MaxKeepAliveRequests) parameters are not foundin my httpd.conf, so is that normal ??
############
my.cnf

interactive_timeout=10
wait_timeout=20
connect_timeout=10
max_user_connections=10
max_connections=500
###########


Thanks for all,...and waiting your help ..
 
Old 04-07-2009, 10:17 PM   #2
black-code
LQ Newbie
 
Registered: Sep 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Plz any help for my problem
 
Old 04-08-2009, 10:57 AM   #3
archangel_617b
Member
 
Registered: Sep 2003
Location: GMT -08:00
Distribution: Ubuntu, RHEL/CentOS, Fedora
Posts: 234

Rep: Reputation: 42
From your description, it sounds like you just have a heavily loaded server. I wouldn't agree that having load equal to the number of CPUs is a problem usually. Load can be much higher before it's really a problem. What's your CPU utilization like? I don't see it in your top output. And if you press '1' in top, it should show you usage per CPU as well.

- Arch
 
Old 04-08-2009, 01:17 PM   #4
suhas!
Member
 
Registered: Mar 2007
Posts: 100

Rep: Reputation: 17
Is the top output taken at the time when apache was running fine or when it was giving sluggish response?

The load average, cpu, memory utilization looks pretty good to me.

Please provide us with the top output and iostat output at the time when apache response is slow.

Quote:
Originally Posted by black-code View Post
Hello AlL,..

I want from experts to help me as my load average is increased and i dont know where is the problem !!

this is my top result :

root@a4s [~]# top
top - 11:30:38 up 40 min, 1 user, load average: 3.06, 2.49, 4.66
Mem: 8168788k total, 2889596k used, 5279192k free, 47792k buffers
Swap: 2031608k total, 0k used, 2031608k free, 1464780k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
15523 mazikaco 16 0 226m 23m 16m S 24.1 0.3 0:08.74 php5
15547 mazikaco 15 0 226m 24m 17m S 17.5 0.3 0:13.74 php5
15516 mazikaco 16 0 226m 27m 20m S 15.9 0.3 0:11.29 php5
15546 mazikaco 16 0 225m 21m 14m S 15.5 0.3 0:09.73 php5
15548 mazikaco 16 0 225m 21m 14m S 13.9 0.3 0:09.40 php5
15522 mazikaco 16 0 226m 23m 16m S 13.5 0.3 0:15.26 php5
2928 mysql 15 0 731m 110m 4112 S 10.6 1.4 3:27.59 mysqld
15517 mazikaco 16 0 225m 26m 19m S 10.2 0.3 0:13.07 php5
15881 mazikaco 15 0 225m 20m 13m S 5.0 0.3 0:01.97 php5
4008 root 15 0 27600 7852 604 S 1.3 0.1 0:43.87 lighttpd
12374 nobody 16 0 71956 6300 2016 S 1.3 0.1 0:01.48 httpd
9565 nobody 15 0 72068 6376 2012 S 1.0 0.1 0:02.74 httpd
12391 nobody 15 0 72008 6324 2016 S 1.0 0.1 0:01.73 httpd
13926 nobody 15 0 71912 6240 2016 S 1.0 0.1 0:00.69 httpd
14368 nobody 15 0 71972 6184 2012 S 1.0 0.1 0:00.82 httpd
15052 nobody 15 0 71912 6204 2008 S 1.0 0.1 0:00.37 httpd
15474 nobody 15 0 71980 6272 2008 S 1.0 0.1 0:00.14 httpd


i have 4 cpus in my server, and i have read before that when the number found in the 15 minutes period exceeds the total number of cpus so there is a load on the server ..

Note that i have daily more than 450,000 visits and this top result was taken with almost 10,000 visits ,,..

AND when the site accepts the 450,000 visits the connection is interrupted and my apache becomes down foer a short time so what is the soln of that load and is the httpd.conf configuration can play a role here , if so please tell me the best?

############
http.conf

timeout 60

and all of these (MinSpareServers,MaxSpareServers,StartServers,MaxClients,MaxRequestsPerChild,KeepAlive,KeepAliveTime out,MaxKeepAliveRequests) parameters are not foundin my httpd.conf, so is that normal ??
############
my.cnf

interactive_timeout=10
wait_timeout=20
connect_timeout=10
max_user_connections=10
max_connections=500
###########


Thanks for all,...and waiting your help ..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
load average AFU jcgam69 Linux - General 1 10-31-2008 03:51 AM
load average? ampex189 Linux - Newbie 2 03-06-2005 07:17 PM
load average approaching 20 kfiralfia Linux - General 5 09-29-2004 09:35 AM
Load average 1.0, 1.0, 1.0 ? belated Linux - Newbie 4 11-30-2003 03:49 PM
Average load Cyth Linux - General 1 01-22-2002 03:33 PM


All times are GMT -5. The time now is 09:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration