LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 11-14-2007, 09:08 PM   #1
DigitalFirefly
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu
Posts: 6

Rep: Reputation: 0
Question phpmyadmin install problems


I followed the steps here to install apache, mysql and php. However when I get to step 3

Quote:
The phpmyadmin configuration file is located at: /etc/phpmyadmin folder.

To set up under Apache all you need to do is include the following line in /etc/apache2/apache2.conf:
I try and edit that file and I get an error saying I don't have permission.



Also when I try and goto http://localhost/phpmyadmin I get a 404 error. When I goto http://localhost it only lists:

Quote:
Index of /
Name Last modified Size Description
[DIR] apache2-default/ 20-Nov-2004 15:16 -
[ ] testphp.php 13-Nov-2007 23:40 21
Apache/2.2.4 (Ubuntu) PHP/5.2.3-1ubuntu6 Server at localhost Port 80
Any help is greatly appreciated. Thanks in advance.

Last edited by DigitalFirefly; 11-15-2007 at 07:50 AM.
 
Old 11-14-2007, 10:34 PM   #2
youngtom
Member
 
Registered: Feb 2005
Location: Rio de Janerio
Distribution: suse 9.1, suse 9.2, redhat enterprise, ubuntu, kubuntu
Posts: 104

Rep: Reputation: 15
To edit a file in /etc, you'll need to use sudo on ubuntu.

For step 3, you'll need to do

sudo vi /etc/apache2/apache2.conf

and type in your password when prompted and then you are prompted.
 
Old 11-15-2007, 12:39 AM   #3
rbroek
LQ Newbie
 
Registered: Jan 2005
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by DigitalFirefly View Post
Also when I try and goto http://localhost/myphpadmin I get a 404 error.
If you use phpmyadmin at the end of your URL, rather than myphpadmin, it should work. Also, this directory will not be listed in the directory listing of http://localhost/...

Last edited by rbroek; 11-15-2007 at 12:41 AM.
 
Old 11-15-2007, 07:49 AM   #4
DigitalFirefly
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by rbroek View Post
If you use phpmyadmin at the end of your URL, rather than myphpadmin, it should work. Also, this directory will not be listed in the directory listing of http://localhost/...
sorry, that was a typo in the post, i was typing phpmyadmin.
 
Old 11-15-2007, 08:24 AM   #5
DigitalFirefly
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by youngtom View Post
To edit a file in /etc, you'll need to use sudo on ubuntu.

For step 3, you'll need to do

sudo vi /etc/apache2/apache2.conf

and type in your password when prompted and then you are prompted.

That worked. Thank you so much. Sorry for the double post.
 
Old 11-15-2007, 04:45 PM   #6
jcvasquez
LQ Newbie
 
Registered: Oct 2007
Location: Guatemala
Distribution: Slackware
Posts: 5

Rep: Reputation: 0
This is how it works for me: I unpacked PHPMyAdmin in htdocs/pma/ (actually, the folder name is not critical). The configuration file is 'config.inc.php' and it's located in the same folder. edit this file (there's also a 'config.sample.inc.php' file you can look at).
JC
 
Old 11-15-2007, 10:40 PM   #7
DigitalFirefly
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu
Posts: 6

Original Poster
Rep: Reputation: 0
Ok, I can get to the log in for phpmyadmin, but now it's asking for a user name and password. It never asked me to set one up. What do I put in?
 
Old 11-16-2007, 09:39 AM   #8
Baloo_PNW
LQ Newbie
 
Registered: Jun 2006
Posts: 12

Rep: Reputation: 0
Quote:
Originally Posted by DigitalFirefly View Post
Ok, I can get to the log in for phpmyadmin, but now it's asking for a user name and password. It never asked me to set one up. What do I put in?
Your MySQL user name and password. The install default for MySQL is
user name: root
password: [no password]
you should change this.

MySQL's documentation is fairly straight forward
http://dev.mysql.com/doc/refman/5.1/...anagement.html
 
Old 11-16-2007, 09:56 AM   #9
Baloo_PNW
LQ Newbie
 
Registered: Jun 2006
Posts: 12

Rep: Reputation: 0
Quote:
Originally Posted by youngtom View Post
To edit a file in /etc, you'll need to use sudo on ubuntu.

For step 3, you'll need to do

sudo vi /etc/apache2/apache2.conf

and type in your password when prompted and then you are prompted.
Those who know vi, love vi those who don't tend to hate it.

[If you want to use a GUI text editor instead of vi type:

for Gnome (Unbuntu users)
sudo gedit /etc/apache2/apache2.conf

for KDE
sudo kwrite /etc/apache2/apache2.conf

[Edited to add:]
Some distros do not allow other users to access X by default. If you attempt either of the above and get a "cannot connect to X server" or "cannot open display" error just try one of the options below
[end edit]


this will bring up a command line editor that while far less powerful is far easier to manipulate than vi.

sudo jpico /etc/apache2/apache2.conf


To avoid the command line entirely you can either look for and open a "super user file manager" in your tool bar, then surf to the file and open it, or most distros offer a way to right click on any launcher icon and run as root. For Suse:
Right click on the icon
Select Put into run dialog
If not expanded expand the options
Look for Run as different user (root is entered as default)
supply the root password and click run.
application is now running as root

Last edited by Baloo_PNW; 11-16-2007 at 12:29 PM. Reason: oh yeah, I forgot about that
 
Old 11-18-2007, 09:04 AM   #10
DigitalFirefly
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu
Posts: 6

Original Poster
Rep: Reputation: 0
Ok, the root password did work. I must have typed it wrong the previous times I was trying it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
phpmyadmin mysql auth problems baird Linux - Software 0 10-12-2007 12:20 AM
phpmyadmin - how to install? smeggle Linux - Newbie 1 08-19-2007 07:09 PM
phpMyAdmin problems Dsupreeme Linux - Server 1 10-07-2006 08:03 AM
MySql and phpMyAdmin problems eagletalontim Linux - Software 1 01-09-2006 08:28 PM
Dependency problems with phpMyadmin in SuSE 8.2 hindenbergbaby Linux - Newbie 3 10-12-2003 01:20 PM


All times are GMT -5. The time now is 03:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration