LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 02-15-2008, 10:50 AM   #1
mcupples
Member
 
Registered: Jun 2006
Location: Orlando
Distribution: FC3, FC5, CentOS4, Ubuntu 6.06
Posts: 57

Rep: Reputation: 15
php_autoconf environment variable issue


I've got a little issue here regarding autoconf. Basically I did this:

----------------------------------------------------------------------------------
[root@www bin]# cd /opt
[root@www opt]# wget http://pecl.php.net/get/memcache-2.1.0.tgz
--10:41:02-- http://pecl.php.net/get/memcache-2.1.0.tgz
=> `memcache-2.1.0.tgz'
Resolving pecl.php.net... 216.92.131.66
Connecting to pecl.php.net|216.92.131.66|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 19,567 (19K) [application/octet-stream]

100%[==================================================================================================== ===================================>] 19,567 92.76K/s

10:41:02 (92.49 KB/s) - `memcache-2.1.0.tgz' saved [19567/19567]

[root@www opt]# gunzip memcache-2.1.0.tgz
[root@www opt]# tar -xvf memcache-2.1.0.tar
package.xml
memcache-2.1.0/CREDITS
memcache-2.1.0/README
memcache-2.1.0/example.php
memcache-2.1.0/config.m4
memcache-2.1.0/config.w32
memcache-2.1.0/php_memcache.h
memcache-2.1.0/memcache.c
memcache-2.1.0/memcache.dsp
[root@www opt]# cd memcache-2.1.0
[root@www memcache-2.1.0]# ls
config.m4 config.w32 CREDITS example.php memcache.c memcache.dsp php_memcache.h README
[root@www memcache-2.1.0]# phpize
Configuring for:
PHP Api Version: 20041225
Zend Module Api No: 20060613
Zend Extension Api No: 220060519
Cannot find autoconf. Please check your autoconf installation and the $PHP_AUTOCONF
environment variable is set correctly and then rerun this script.
----------------------------------------------------------------------------------

I've found autoconf and did:

----------------------------------------------------------------------------------
[root@www memcached-1.2.4]# export PHP_AUTOCONF="/usr/bin/"
[root@www memcached-1.2.4]# pecl install memcache
downloading memcache-2.2.3.tgz ...
Starting to download memcache-2.2.3.tgz (27,304 bytes)
.........done: 27,304 bytes
11 source files, building
running: phpize
Configuring for:
PHP Api Version: 20041225
Zend Module Api No: 20060613
Zend Extension Api No: 220060519
/usr/bin/phpize: /tmp/pear/cache/memcache-2.2.3/build/shtool: /bin/sh: bad interpreter: Permission denied
Cannot find autoconf. Please check your autoconf installation and the $PHP_AUTOCONF
environment variable is set correctly and then rerun this script.

ERROR: `phpize' failed
----------------------------------------------------------------------------------

I'm not 100% sure what I should change $PHP_AUTOCONF to. Any ideas?
 
Old 02-15-2008, 01:44 PM   #2
mcupples
Member
 
Registered: Jun 2006
Location: Orlando
Distribution: FC3, FC5, CentOS4, Ubuntu 6.06
Posts: 57

Original Poster
Rep: Reputation: 15
Aw, come on. No one knows?
 
Old 05-14-2008, 08:57 AM   #3
linuxarchitect
LQ Newbie
 
Registered: May 2008
Posts: 1

Rep: Reputation: 0
> /usr/bin/phpize: /tmp/pear/cache/memcache-2.2.3/build/shtool: /bin/sh: bad interpreter: Permission denied

You probably know by now, but others like me might still be looking for the answer...

Check that you can execute scripts out of the /tmp directory. E.g. on my system:

# mount -l | grep /tmp
/dev/sda2 on /tmp type ext3 (rw,noexec,nosuid,nodev) [/tmp]

I remounted /tmp without the noexec flag and then the install worked.

Another option for those who can't remount /tmp should be to use a different temporary directory.

# pear config-set temp_dir /var/tmp/pear/temp
config-set succeeded
 
Old 08-13-2009, 06:16 AM   #4
cubixwebsolutions
LQ Newbie
 
Registered: Aug 2009
Posts: 1

Rep: Reputation: 0
Thumbs up Nice explanation

The above comment to remount the tmp file by making it executable definitely did the job for me!

Just a little more help to others reading this. To remount the tmp directory, just use:
# mount -o remount,exec /tmp

And after you are done with the installation, for security purpose, run:
# mount -o remount,noexec /tmp

Cheers!

Cubix Web Solutions
 
  


Reply

Tags
autoconf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Environment variable vedanu Programming 1 05-17-2007 07:20 AM
Environment variable.. manomohan Programming 1 02-26-2007 11:27 PM
environment variable gamor Linux - Newbie 4 04-30-2005 05:28 PM
environment variable mimi Linux - Newbie 1 04-10-2002 08:29 AM
environment variable mimi Linux - General 2 04-10-2002 07:45 AM


All times are GMT -5. The time now is 04:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration