LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 02-10-2010, 12:23 PM   #1
Actionscript3
LQ Newbie
 
Registered: Jan 2009
Posts: 19

Rep: Reputation: 0
Exclamation PHP (XAMPP) install ssh2 module CentOS 5


Hi,

I am running CentOS 5 with XAMPP PHP 5.3.1

I'd like to config SSH support for PHP.

I first installed the libssh2,

then download ssh2-0.11.0 from http://pecl.php.net/package/ssh2

issues the following commards and get the error response after 'make'

#/opt/lampp/bin/phpize

#./configure –with-ssh2 –with-php-config=/opt/lampp/bin/php-config-5.3.1

#make

....

/root/tmp/ssh2-0.11.0/ssh2.c: At top level:
/root/tmp/ssh2-0.11.0/ssh2.c:1336: error: 'ZEND_DEBUG' undeclared here (not in a function)
/root/tmp/ssh2-0.11.0/ssh2.c:1353: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'zend_module_entry'
make: *** [ssh2.lo] Error 1

----------------------------------------------

Can anyone here?

Thanks!
 
Old 04-10-2010, 05:02 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 26,953
Blog Entries: 54

Rep: Reputation: 2733Reputation: 2733Reputation: 2733Reputation: 2733Reputation: 2733Reputation: 2733Reputation: 2733Reputation: 2733Reputation: 2733Reputation: 2733Reputation: 2733
Fist of all please be aware that XAMPP is not for production use and is not a supported method of installing software in Centos. If you would like to move your product over to production and retain compatibility then please consider installing your LAMP stack as Centos supports it by installing Apache, MySQL and PHP from the Centos repo. If you insist on running XAMPP please see:
http://www.linuxquestions.org/questi...26#post3501826
http://www.linuxquestions.org/questi...36#post3731636
http://www.linuxquestions.org/questi...92#post3859092

As for your question there may be a php-pecl-ssh2 RPM package available from the Remi repo. This may provide an easy way out but please be aware this repo is not as "trusted" as say RPMforge or EPEL.


//NTLB
 
Old 04-13-2010, 01:31 PM   #3
lexington2
LQ Newbie
 
Registered: Apr 2010
Posts: 2

Rep: Reputation: 0
Personally, I'd use phpseclib, a pure PHP SSH2 implementation. php-pecl-ssh2 doesn't even work on PHP 5.3:

http://pecl.php.net/bugs/bug.php?id=16727

Sure, there's a patch available to get it working, but do you really want to be running software that's no longer actively maintained? What are you going to do when PHP 5.4 is released? Wait around for months on, checking php.net every day for the day when someone submits a patch, only to have to apply that patch yourself?
 
  


Reply

Tags
ssh, xampp


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suhosin php module install on CentOS 5.3 spaceageliving Linux - Security 3 10-08-2009 11:46 AM
LXer: Installing The PHP-MemCache Module On CentOS 5.0 LXer Syndicated Linux News 0 07-18-2007 03:01 PM
LXer: Installing The PHP-MSSQL Module On CentOS 5.0 LXer Syndicated Linux News 0 06-11-2007 10:46 AM
xampp and php charnel Programming 3 07-26-2005 02:20 PM
php static module & dynamic module install. eye Linux - Software 0 10-18-2003 12:16 PM


All times are GMT -5. The time now is 08:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration