-   Linux - Server (
-   -   PHP enabled server won't run a script that works on other servers. (

devwink 02-12-2010 02:06 AM

PHP enabled server won't run a script that works on other servers.
Thanks People,

I have a script that works fine on a commercial server and my CentOs Box at home but doeasn't work with another commercial server (Where we need it to).

I have pulled the PHPINFO.PHP from both and wondering if someone could tell me which parameters to compare when the following happens:

The script seems to do the HTML/Java and outputs the PHP script on the page , but this site has many other PHP scripts working fine:

jayakrishnan 02-12-2010 02:21 AM

Must be your PC, works fine on both sites for me, i can see the PHIINFO output for both the sites

devwink 02-12-2010 03:14 AM

Thanks for the reply,
The PHP Info's are fine , its this one that freaks out

But it works great here: note that it has alraedy installed so it reads as such.


Thanks again for your suggestions.

bathory 02-12-2010 09:03 AM


Check if "short_open_tag=Off" in php.ini and set it to "On".
Restart apache and see if it helps


devwink 02-12-2010 10:05 AM

Thanks bathory,

I remember getting further when finding and replacing <? with <?php

I think yr on the money, will report back

devwink 02-12-2010 10:39 AM

Thanks bathory,
You Da man,,... Case closed.. Thanks again

bathory 02-12-2010 04:39 PM

If you want, you can mark the thread solved using thread tools


All times are GMT -5. The time now is 01:29 PM.