LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   PHP 5.3 on Debian (http://www.linuxquestions.org/questions/linux-server-73/php-5-3-on-debian-741011/)

MagicTom 07-18-2009 10:24 AM

PHP 5.3 on Debian
 
PHP 5.3 was recently released (exciting!) and added to the Debian Experimental repository. The repository and install instructions are located at http://osdir.com/ml/php-general/2009-07/msg00040.html .

Problem is, the line they give to install php 5.3 doesn't seem to help with the dependencies. Executing "apt-get -t experimental php5" on Debian Etch gives me:
Code:

The following packages have unmet dependencies:
  php5: Depends: libapache2-mod-php5 (>= 5.3.0-2) but it is not going to be installed or
                libapache2-mod-php5filter (>= 5.3.0-2) but it is not going to be installed or
                php5-cgi (>= 5.3.0-2) but it is not going to be installed
E: Broken packages

Switching it to php5-cgi (which is really all I need at this point) gives me:
Code:

The following packages have unmet dependencies:
  php5-cgi: Depends: libdb4.7 but it is not installable
            Depends: libgssapi-krb5-2 (>= 1.6.dfsg.2) but it is not installable
            Depends: libk5crypto3 (>= 1.6.dfsg.2) but it is not installable
            Depends: libkrb5-3 (>= 1.6.dfsg.2) but it is not installable
            Depends: libpcre3 (>= 7.7) but 6.7+7.4-4 is to be installed
            Depends: libssl0.9.8 (>= 0.9.8f-5) but 0.9.8c-4etch5 is to be installed
            Depends: libxml2 (>= 2.6.28) but 2.6.27.dfsg-6 is to be installed
E: Broken packages

So, it's fantastic that PHP 5.3 is in the repository and all, but it's not doing me a lot of good if apt won't find the rest of the packages it needs. But I'm not super apt-savvy, so if anyone has any tips it would be hugely appreciated!

AlucardZero 07-19-2009 07:38 AM

What is your sources.list now?

MagicTom 07-19-2009 07:47 AM

Well I've been starting up EC2 nodes to test this before I do it on my webserver (there's a whole lot of sites on there at risk if I do this wrong ;-)) But every time I get one, my sources.list looks like this:

Code:

deb http://ftp.debian.org/debian/ etch main
deb-src http://ftp.debian.org/debian/ etch main

deb http://security.debian.org/ etch/updates main contrib
deb-src http://security.debian.org/ etch/updates main contrib

deb http://ftp.debian.org/debian/ experimental main contrib
deb-src http://ftp.debian.org/debian/ experimental main contrib

Thanks for replying!

AlucardZero 07-19-2009 09:44 AM

Ok, etch is oldstable. I would wager that php5.3 in experimental isn't meant to be able to run on Etch. Perhaps not even Lenny (stable).

Picking one package .. I'm mostly right. libxml2 (>= 2.6.28) is not available in Etch but is in Lenny.

You can either upgrade your system to Lenny, or attempt to build php5 from experimental on your Etch system. With all the dependencies it probably isn't worth it, but you can try something like:
apt-get install build-essential
apt-get build-dep php5
apt-get source -b -t experimental php5
And see if it will build. If it does,
dpkg -i php5-somethingsomething.deb

MagicTom 07-19-2009 12:25 PM

Thanks for the help, Alucard! Your prediction was right on -- I couldn't get it to install cleanly in Lenny either, but I've successfully taken a server from etch to squeeze and installed php 5.3.0 with all my modules.

Thanks again!


All times are GMT -5. The time now is 04:41 PM.