LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 06-15-2009, 10:11 AM   #1
Datakraft
LQ Newbie
 
Registered: May 2009
Posts: 10

Rep: Reputation: 0
Permission problem with Wordpress


Hi!

Code:
sudo chmod -R 755 /data/nissadalen
This will make the whole directory writable for the user, i think. But when im trying to run the WordPress installation i got this error message

Code:
Sorry, I can't write to the directory. You'll have to either change the permissions on your WordPress directory or create your wp-config.php manually.
Why?
 
Old 06-15-2009, 12:52 PM   #2
rweaver
Senior Member
 
Registered: Dec 2008
Location: Louisville, OH
Distribution: Debian, CentOS, Slackware, RHEL, Gentoo
Posts: 1,833

Rep: Reputation: 163Reputation: 163
Quote:
Originally Posted by Datakraft View Post
Hi!

Code:
sudo chmod -R 755 /data/nissadalen
This will make the whole directory writable for the user, i think. But when im trying to run the WordPress installation i got this error message

Code:
Sorry, I can't write to the directory. You'll have to either change the permissions on your WordPress directory or create your wp-config.php manually.
Why?
Depends on the owner and if you're using the correct location.

755 is read, write, execute for owner, read and execute for group and everyone. So unless the webserver is running as the owner of the files it won't be able to write.

Really files shouldn't be 755, they should be 644 for the same effective permissions.
 
Old 06-16-2009, 01:08 AM   #3
Datakraft
LQ Newbie
 
Registered: May 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Hello again!
How do I do if there are virtual users?
The point is that this server will act web host, and that users should not need to fuss with a lot of rights when they are uploading files via FTP and run problem-free PHP in the browser, such as WordPress.

How do I do for the user to the full rights to
Code:
/data/nissadalen
?
 
Old 06-16-2009, 02:42 PM   #4
rweaver
Senior Member
 
Registered: Dec 2008
Location: Louisville, OH
Distribution: Debian, CentOS, Slackware, RHEL, Gentoo
Posts: 1,833

Rep: Reputation: 163Reputation: 163
Quote:
Originally Posted by Datakraft View Post
Hello again!
How do I do if there are virtual users?
The point is that this server will act web host, and that users should not need to fuss with a lot of rights when they are uploading files via FTP and run problem-free PHP in the browser, such as WordPress.

How do I do for the user to the full rights to
Code:
/data/nissadalen
?
Virtual users can mean a lot of things, what do you mean in particular?
 
Old 06-17-2009, 03:00 AM   #5
Datakraft
LQ Newbie
 
Registered: May 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by rweaver View Post
Virtual users can mean a lot of things, what do you mean in particular?
vsftpd with MySQL authenticate.
 
Old 06-17-2009, 03:24 AM   #6
peonuser
Member
 
Registered: Mar 2008
Location: Where ever I am.
Distribution: Various
Posts: 173
Blog Entries: 135

Rep: Reputation: 21
Quote:
Originally Posted by Datakraft View Post
vsftpd with MySQL authenticate.
When setting up a web directory you usually have to do both a chown and a chmod recursively.
 
Old 06-17-2009, 03:38 AM   #7
EricTRA
Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 18 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290
Hi there,

I'm using WordPress also in our company and you should check to see if the webuser is the owner of that directory. All work in WordPress gets done using that particular webuser.
Directory rights on my system are set to 755 and owned by the webuser:webgroup profile.
File rights are set to 644 and also owned by the webuser:webgroup profile.

And everything works like a charm.
 
Old 06-24-2009, 04:06 AM   #8
Datakraft
LQ Newbie
 
Registered: May 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Hi again!
I have discover how i can solve this. I need these users www-data and vsftpd to access the directory /data/nissadalen but i dont know how to do this.

How do i do this?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: The new WordPress LXer Syndicated Linux News 0 04-09-2008 02:10 AM
New to Wordpress subaruwrx General 0 10-31-2007 12:22 PM
permission problem - "You don't have permission to access" radone Linux - General 3 07-24-2006 10:23 AM
Installing WordPress on FC5 - Mysql / PHP problem ArthurDent Fedora 1 06-25-2006 04:58 PM
wordpress don't working fllabron Linux - Software 2 09-08-2005 04:27 PM


All times are GMT -5. The time now is 08:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration